OFFICE: Common

OFFICE: Общие советы

Новинки Office 2010

Изменения в системе активации Office 2010

Мгновенное создание скриншотов. В новой редакции офиса предусмотрена функция, отвечающая за съёмку любой части рабочего стола Windows (или окна конкретной программы) и автоматическую вставку снимков в содержимое документа. Найти данный инструмент можно на вкладке Insert.

Очистка фона на картинках и фотографиях. В 2010-й версии офиса предусмотрено автоматизированное средство для удаления фона на изображениях. Оно позволяет за считанные секунды ликвидировать с любой картинки лишние объекты, не обращаясь к специализированным графическим редакторам. Кроме того, имеющиеся в составе пакета инструменты позволяют обрезать фотографии, накладывать различные эффекты и рамки на изображения, корректировать их яркость и выполнять прочие операции.

Предварительный просмотр содержимого, вставляемого из буфера обмена. Обновленный Microsoft Office позволяет "на лету" просматривать, как будут выглядеть добавляемые в документ данные, будь то изображение или текст. При наведении курсора мыши на значок вставки объекта контекстное меню становится прозрачным, а находящиеся в буфере обмена данные показываются внутри редактируемого документа. При отведении курсора картинка принимает прежний вид, а при щелчке - изменения вносятся в документ. Подробнее можно прочитать в статье Улучшенная функция вставки в Office 2010

Взаимодействие с онлайновыми видеосервисами. Еще одна любопытная особенность программы - возможность добавления в файлы презентаций флэш-роликов, опубликованных на таких сайтах, как YouTube, RuTube, Google Video и других. Вещь нужная и полезная, особенно в свете популярности мультимедийных интернет-сервисов. Для вставки видео достаточно ввести в специальную форму код ролика.

Монтаж видео. Возможности PowerPoint 2010 позволяют пользователю редактировать вставляемые в презентацию ролики, а именно: удалять лишние кадры, добавлять всевозможные эффекты, в том числе и трёхмерные. Чтобы получить доступ к инструментарию для правки видео, нужно один раз щёлкнуть мышью по ролику и открыть вкладку Video Tools.

Конвертирование презентаций в видеофайл. Если раньше для преобразования слайдов в видеоформат приходилось пользоваться сторонними утилитами, то в новой версии офиса для выполнения аналогичной задачи достаточно щёлкнуть по расположенной в верхнем левом углу кнопке Office, затем перейти в меню Share и проследовать по ссылке Create a Video. В настройках программы можно указать качество создаваемого фильма и указать паузу, которую PowerPoint будет выдерживать перед демонстрацией каждого слайда. Запись видео осуществляется в файл формата WMV.

Добавление мини-графиков в ячейки таблиц Excel. В обновлённом табличном процессоре имеется опция Sparklines, с помощью которой можно размещать компактные графики непосредственно в ячейках таблицы. В некоторых случаях они могут существенно упростить восприятие и визуальный анализ представленной в документе информации, особенно, если она доверху напичкана цифровыми значениями.

Скрытие ленточного меню. Не секрет, что реализованная в Ribbon-интерфейсе лента с вкладками и управляющими элементами занимает много места на экране. Осознавая данный факт и идя навстречу пользователям, разработчики Office 2010 реализовали в новом пакете клавишу, скрывающую массивное меню с глаз долой. Расположена заветная кнопка в правом верхнем углу слева от клавиши вызова справочной документации.

Перевод слов "на лету". В меню "Review -> Translate" текстового редактора Word 2010 предусмотрен новый инструмент Mini Translator, выполняющий мгновенный перевод слов, находящихся под курсором мыши. Прелесть данной надстройки обязательно оценят те, кто занимается переводами текстов и много работает с иноязычными материалами.

И десятая - но далеко не последняя фича 2010-го офиса - опция The Conversation View, доступная в Outlook и представляющая списки писем в виде цепочек обсуждений, упрощающих отслеживание и управление потоками электронной корреспонденции.

Сохранение в старых форматах

По умолчанию документы сохраняются в новых форматах: docx, xlsx и так далее. Можно настроить программы таким образом, что автоматически документы сохранялись в старых форматах.

Откройте Word 2007/2010, нажмите ALT + F, чтобы открыть меню File. Выберите команду Options и щелкните на элементе Save в левой панели. В выпадающем списке Save files in this format выберите Word 97-2003 Document (*.doc) и щелкните OK.

Аналогичные действия можно проделать для Excel и PowerPoint.

Секретные данные

Знаете ли вы, что при создании документов Microsoft Office в них помимо основного текста, таблиц, графиков и картинок сохраняются имена авторов, сведения о совместной работе, различные метаданные, примечания и прочие скрытые от рядового пользователя элементы, которые могут содержать информацию конфиденциального характера? И, как сделать так, чтобы посторонний человек не смог обнаружить и прочитать подобного рода сведения?

Существует несколько способов воспрепятствовать просмотру скрытой в офисных файлах информации. Для Office 2003/XP сущеcтвует утилита от Microsoft Rhdtool, позволяющая ликвидировать все лишние данные из документов Word, Excel и PowerPoint. После инсталляции она интегрируется в меню "Файл" офисного пакета и доступна для использования всякий раз перед отправкой документа по e-mail или его публикацией в Сети. При работе с надстройкой всегда следует сохранять результаты в файле с новым именем, не изменяя при этом содержимое исходного файла. Подобная предусмотрительность позволяет сохранить копию документа, содержащую первоначальные данные. И еще один важный момент: средство удаления скрытых данных нельзя использовать для обработки файлов, защищенных цифровой подписью или с помощью средств Information Rights Management.

В Office 2007 уже встроена возможность удаления комментариев, свойств документа, личной информации, скрытого текста, XML-данных, "водяных знаков" и примечаний - Инспектор документов. Инспектор документов располагается в общем меню офисных приложений, открывающемся по щелчку мыши на кнопке Microsoft Office, во вложенном меню команды "Подготовить". Диалоговое окно инспектора содержит пять типов информации, которые можно отыскать и удалить из документа. Опять-таки, столь серьезный инструмент следует применять к копии документа, потому как восстановить данные, удаляемые средством, не всегда возможно.

Кроме того, избавиться от личных сведений и прочей скрытой информации, сохраняемой в свойствах файла формата doc, можно средствами бесплатной утилиты Doc Scrubber. Программа находит в документах WORD секретные данные и ликвидирует их. Программа работает с документами Word 97, 2000, XP, 2003, но не с документами docx.

Панель быстрого доступа

В Office XP и выше для добавления папки на панель быстрого доступа в диалоге открытия/сохранения файлов не обязательно лезть в реестр и что-то там исправлять. В диалоге открытия/сохранения файлов выбираем папку, ярлык которой хотим добавить и выбираем в меню Сервис | Добавить на панель адресов


EXCEL: Общие советы

Параметры командной строки

путь к книге | имя файла
Данный параметр не требует наличия ключа. Запуск Excel и открытие указанного файла. Пример: excel.exe "c:\My Folder\book1.xlsx"
/r путь к книге | имя файла
Открытие указанной книги только для чтения. Пример: excel.exe /r "c:\My Folder\book1.xlsx"
/t путь к книге | имя файла
Запуск Excel и открытие указанного файла в качестве шаблона. Пример: excel.exe /t "c:\My Folder\book_name.xlsx"
/n путь к книге | имя файла
Также как и в /t, запуск Excel и открытие указанного файла в качестве шаблона. Пример: excel.exe /n "c:\My Folder\book_name.xlsx"
/e или /embed
Запрет появления загрузочного экрана Excel и открытия пустой книги. Пример: excel.exe /e
/p путь к книге
Задание активной рабочей папки (например, папки, которая открывается в диалоговом окне Сохранить как). Пример: excel.exe /p "c:\My Folder"
/s или /safemode
Excel будет пропускать все файлы, хранящиеся в папках запуска, такие как папка каталог начальной загрузки по умолчанию, находящийся в папке, в которую установлено приложение Excel или выпуск 2007 системы Microsoft Office. Пример: excel.exe /s
/m
Создание новой книги с одним листом макроса XLM. Пример: excel.exe /m
/a КодПрог
Запуск Excel и загрузка надстройки с идентификатором КодПрог. Пример: excel.exe /a MyProgId.MyProgID2.1

Чтение вслух

Excel 2007 умеет читать по-английски. Жмём по кнопке настройки панели быстрого доступа | Выбираем Другие команды, переключаем выбор команд на Все команды и добавляем кнопку Проговорить ячейки. Теперь, когда вы выделите ячейку и нажмете на добавленную кнопку, то услышите голос.

Excel позволяет давать координаты ячейкам только с помощью цифр - по вертикали и горизонтали. Делается это с помощью Сервис | Параметры | Общие | Стиль ссылок R1C1
Excel 2007: Параметры Excel | Формулы | Работа с формулами | Стиль ссылок R1C1

В Excel возможно одновременное редактирование файлов несколькими пользователями. Например, ваш коллега может вводить данные в книгу параллельно с вами. Для этого поместите книгу в папку, доступную для других пользователей, выполните команду Сервис | Доступ к книге и установите флажок Разрешить изменять файл нескольким пользователям одновременно. Если вам нужно ограничить доступ к общей книге, то выполните следующие действия:

  • Выполните команду Сервис | Защита | Защитить книгу и дать общий доступ. Установите флажок Общий доступ с исправлениями.
  • Введите пароль в поле Пароль (необязательно).
  • Щелкните на кнопке ОК.

Теперь никто не сможет открыть книгу, пока вы не сообщите ему пароль.

В Excel, как и в Word, встроена автоматическая проверка орфографии. Поэтому если текст, введенный в ячейку, содержит орфографическую ошибку, то программа подчеркнет его красной волнистой линией.

Если вы работаете с небольшим количеством документов, то вам достаточно четырех файлов, которые программа запоминает по умолчанию. Если же вы работаете с большим числом документов, то можете изменить число запоминаемых файлов следующим образом:

  1. Выберите в меню Сервис | Параметры | Вкладка Общие
  2. В строке Помнить список файлов, до укажите требуемое количество файлов от 1 до 9 и щелкните на кнопке ОК

Соответственно, если вы работаете за чужим компьютером, то имеет смысл отключить данную функцию запоминания последних открываемых файлов, убрав галочку из флажка Помнить список файлов, до.

С помощью функции автоматического сохранения документа можно задать интервал времени, через который программа будет сохранять документ вместо пользователя. В этом случае при сбое компьютера вы сможете восстановить свой документ. Чтобы включить функцию автоматического сохранения сделайте следующее:

  1. Выберите в меню Сервис | Параметры | вкладка Сохранение
  2. В строке Сохранять данные для автовосстановления каждые минут укажите требуемый промежуток времени. По умолчанию выставлено значение 10 минут. Вы можете увеличить это значение до двух часов или уменьшить до одной минуты.

В левой части диалогового окна Открытие документа (Файл | Открыть) находятся ярлыки папок, документы из которых открываются чаще всего. Это так называемые папки быстрого доступа. По умолчанию здесь находятся следующие записи:

  • Мои последние документы - документы, с которыми пользователь работал недавно
  • Рабочий стол - файлы, которые находятся на Рабочем столе
  • Мои документы - документы, которые находятся в папке Мои документы
  • Мой компьютер - быстрый доступ к дискам
  • Мое сетевое окружение - документы, доступные по локальной сети
Можно настроить папки быстрого доступа под свои нужды.
  1. Щелкните на области ярлыков быстрого доступа правой кнопкой мыши и выберите в контекстном меню пункт Мелкие значки. Значки папок станут занимать меньше места и освободится место для собственных папок.
  2. Выберите в диалоговом окне нужную папку и выделите ее.
  3. Нажмите кнопку Сервис и выберите пункт Добавить на панель адресов.
Раньше для достижения подобного результата приходилось использовать системный реестр.

По умолчанию Microsoft Excel при вызове пункта Открыть выводит окно Открытие документа с содержимым папки Мои документы. Если вы сохраняете свои рабочие книги не в этой папке, а в какой нибудь другой, то можете изменить отображаемую по умолчанию директорию. Тем самым вы сэкономите время, так как избавитесь от необходимости каждый раз переходить в нужную папку. Для этого

  1. Выберите в меню Сервис | Параметры
  2. Перейдите на вкладку Общие
  3. В строке Рабочий каталог укажите путь к требуемой папке
    4. .
  4. Нажмите кнопку ОК

В Excel'e есть возможность защитить от изменения отдельный лист. Для этого надо выбрать пункт меню Сервис->Защита->Защитить лист. Если вы хотите подредактировать его, то защиту надо снять с помощью пункта меню Сервис->Защита->Снять защиту.


EXCEL: Горячие клавиши

Горячие клавиши и комбинации клавиш

Панель инструментов Стандартная

  • Создать - Ctrl+N
  • Открыть - Ctrl+O
  • Сохранить - Ctrl+S
  • Печать - Ctrl+P
  • Орфография - F7
  • Вырезать - Ctrl+X
  • Копировать - Ctrl+C
  • Вставить - Ctrl+V
  • Отменить - Ctrl+Z
  • Вернуть - Ctrl+Y
  • Добавить гиперссылку - Ctrl+K
  • Автосумма - Alt+=

Панель инструментов Форматирование

  • Список Размер - Ctrl+Shift+P
  • Список Шрифт - Ctrl+Shift+F
  • Кнопка Полужирный - Ctrl+B
  • Кнопка Курсив - Ctrl+I
  • Кнопка Подчеркнутый - Ctrl+U
  • Кнопка Денежный формат - Ctrl+Shift+$
  • Кнопка Процентный формат - Ctrl+Shift+%
  • Кнопка Границы - Ctrl+Shift+&

Некоторые горячие клавиши для Excel, позволяющие более комфортно перемещаться по листу, между листами и рабочими книгами:

  • PAGE DOWN - переход на один экран вниз;
  • PAGE UP - переход на один экран вверх;
  • ALT+PAGE DOWN - смещение на один экран вправо;
  • ALT+PAGE UP - смещение на один экран влево;
  • CTRL+END - переход в последнюю ячейку на листе;
  • CTRL+PAGE DOWN - переход на следующий лист;
  • CTRL+PAGE UP - переход на предыдущий лист;
  • CTRL+F6 - переход в следующую рабочую книгу или окно (это так же справедливо и для Word).


Cells

Ячейки

Вступление

Ячейки являются основным элементом таблицы Excel. В эти ячейки записывается различная информация: числа, формулы, текст и другие данные. Чтобы ввести данные в ячейку, нужно щелкнуть на ней мышью и ввести информацию. Ячейка, на которой в данный момент установлен маркер, называется активной.

Столбцы и строки электронной таблицы имеют заголовки, которые расположены вдоль верхней левой границы таблицы. Заголовки столбцов обозначаются латинскими буквами от А до IV, всего столбцов 256, заголовки строк обозначаются арабскими цифрами от 1 до 65 356. Таким образом, самая большая таблица, созданная в программе, теоретически может содержать более 16 млн ячеек. Таким образом, каждая ячейка имеет свой уникальный адрес, который состоит из имени столбца и номера строки (например, А5, С65). Адрес активной ячейки отображается в поле Имя, которое расположено под панелями инструментов, слева от строки формул.

Excel позволяет вносить в таблицу данные, ширина которых больше ширины ячейки, но такие данные, возможно, будут выведены не полностью. Длинные строки текста могут переходить на соседние ячейки, если они свободны В противном случае эти строки прерываются на границе ячейки. Если число не помещается в ячейку, то оно или выводится в показательной форме (например, 3.14E+12, или заменяется знаками решетки. Имейте в виду, что в вычислениях используется даже те данные, которые не помещаются в ячейке. Текст и числа будут выведены полностью, если увеличить ширину столбца до нужного размера.

Если вы хотите вернуться к активной ячейке, которая не видна на экране,то воспользуйтесь сочетанием клавиш Ctrl+Backspace (можно также нажать одну из клавиш управления курсором). При выполнении данного действия активной станет соседняя ячейка относительно той, которая была активной ранее. Таким образом, вы вернетесь к нужной части таблицы.

Не все знают, как удобнее в Excel переместиться на нужную ячейку! Необязательно курсор мыши тянуть до нужного вам столбца или строки. Можно всего лишь в поле имени (поле слева от строки формул, в котором отображается имя выбранной ячейки) прописать букву столбца и номер строки. Вот и все перед вами ваша ячейка.

Вставка специальных символов

Если вам необходимо вставить специальные символы, которых нет на клавиатуре, предположим греческую букву, то воспользуйтесь командой Вставка | Символ, которая открывает диалоговое окно Символ (Excel 2002 и выше). Выделите нужный знак и щелкните на кнопке Вставить. Если вы работаете с более ранними версиями Excel, то воспользуйтесь программой Таблица символов (charmap.exe), входящей в состав Windows.

Автозамена

Если вам нужно отключить автозамену (например, adn меняется на and), то выполните команду Сервис | Параметры автозамены и снимите флажок Заменять при вводе на вкладке Автозамена.

Маркер автозаполнения

Если вам надо ввести в ячейки регулярные последовательности чисел, например 1, 2, 3, 4, 5 и так далее, то воспользуйтесь маркером автозаполнения, который позволяет вводить числа автоматически. Маркер автозаполнения - это небольшой черный квадратик, расположенный в правом нижнем углу выделенной ячейки. При наведении на него указатель мыши примет форму небольшого крестика. Если ввести в ячейку число, а затем щелкнуть на маркере автозаполнения и, удерживая нажатой кнопку мыши, растянуть ячейку на соседние ячейки в любом направлении, то это число появится в каждой выделенной ячейке. Если же выделить две последовательные ячейки, в которых введены числа, а затем воспользоваться маркером автозаполнения, Excel проанализирует числа и заполнит ячейки, используя информацию о числовой последовательности исходных ячеек. Например, если в ячейке введено значение 1, а в ячейке 2 - значение 2, то при выделении при помощи маркера автозаполнения ячеек ВЗ, В4 и В5 в них появятся значения 3, 4 и 5 соответственно. При этом еще в процессе выделения вы сможете увидеть, какое значение будет внесено в каждую ячейку. Если в первых двух ячейках ввести 1 и 3, то следующими будут числа 5, 7, 9 и т.д. Существует и другой способ - в первой ячейке набрать первую цифру из этого ряда и выделить область удерживая клавишу Ctrl. В этом случае также ячейки будут заполняться по порядку.

А если данные в выделенных ячейках не образуют регулярную прогрессию? Тогда Excel аппроксимирует новые члены с использованием линейной прогрессии. Иногда это бывает очень удобно. Предположим, у вас имеются сводные данные по объемам продаж за 9 месяцев. Чтобы узнать, какой объем будет достигнут в будущем при сохранении текущих темпов, выделите ячейки и перетащите маркер заполнения.

Существуют и другие варианты приращения. Если при перемещении маркера заполнения использовать правую кнопку мыши, то на экране появится контекстное меню для выбора типа приращения:

  • Линейное приближение генерирует арифметическую прогрессию, которая используется по умолчанию.
  • Экспоненциальное приближение генерирует геометрическую прогрессию, в которой члены возрастают или убывают по экспоненциальному закону. Например, 1, 2, 4, 8.
  • Прогрессия выводит диалоговое окно Прогрессия, которое позволяет выбрать способ продолжения последовательности — скажем, арифметическая или геометрическая прогрессия. Установка переключателя Автозаполнение приводит к тому же результату, что и простое перетаскивание маркера заполнения.

Настройка параметров последовательности в окне Прогрессия

В окне Прогрессия можно настроить последовательность по своему вкусу. Предположим, у вас есть три параметра: начальное значение, конечное значение и шаг последовательности. Тогда с помощью полей Шаг и Предельное значение создаем последовательность, начиная со значения, введенного в ячейке листа. Шаг - это разность между двумя соседними элементами. Предположим, мы ввели в ячейку число 3.Выделите 4 ячейки под выбранной ячейкой и выполните команду Правка | Заполнить | Прогрессия. Установите шаг 5 и предельное значение 45. Excel заполнит ячейки числами 3,8,13,18. Поэкспериментируйте сами.

Построение собственных последовательностей

Можно создавать свои нестандартные последовательности. Допустим, вы хотите ввести в таблицу повторяющие слова. Введите в ячейки слова один, два, три. Выделите их и перетащите маркер заполнения по всем ячейкам, в которых должна повторяться эта последовательность.

С помощью маркера заполнения также удобно дублировать содержимое ячеек. Предположим, вам надо скопировать содержимое ячейки в другие ячейки той же строки или столбца. Щелкните на нужной ячейке и перетащите маркер заполнения по ячейкам, в которых требуется продублировать значение. Чтобы продублировать содержимое ячейки в прямоугольном блоке, выделите копируемую ячейку и перетащите маркер заполнения сначала по горизонтали. Отпустите кнопку мыши. Снова захватите маркер заполнения, который действует уже для всего горизонтального диапазона, выделенного в данный момент, и перетащите его по вертикали.

Вставка новых ячеек

Быстро вставить несколько ячеек в Excel можно, если пометить ячейку, после которой надо вставить новые ячейки, поместить курсор мыши в правый нижний угол ячейки в виде маленького черного квадрата, нажать Shift (курсор поменяет вид) и, удерживая нажатой левую кнопку мыши, растянуть рамку на столько ячеек, сколько надо вставить.

В ячейке Excel может находиться более одной строки текста - можно вручную вставлять "разрыв строки" или абзаца. После нажатия Alt+Enter курсор внутри ячейки переносится на следующую строку. Процесс переноса на следующую строку можно автоматизировать, если отметить пункт "Переносить по словам" в закладке "Выравнивание" (Формат-Ячейки).

Для расчета формулы в какой-то ячейке Excel не обязательно перед формулой ставить знак "=". Вместо него можно поставить "+". При этом в формуле можно также использовать значения каких-то ячеек. Это может быть удобно для тех, кто осуществляет набор данных на малой цифровой клавиатуре.

Для того чтобы быстро просуммировать значение нескольких ячеек, идущих подряд в строке или столбце (без лишних движений мышкой, а только с клавиатуры), в ячейке, где нужно значение суммы, нажать "ALT"+"=" и Enter. При этом данные для суммирования будут браться из ячеек, идущих подряд, выше или левее той, в которой вы находитесь.

В Excel ввод данных осуществляется в отдельные ячейки. Чтобы выбрать ячейку, в которую необходимо ввести данные, нужно сделать ее активной. Для этого можно щелкнуть на ней левой кнопкой мыши или воспользоваться клавишами управления курсором на клавиатуре. Когда ячейка является активной, можно начинать ввод данных с клавиатуры. При этом вводимый текст или числа появляются не только в ячейке, но и в строке формул, в которой также возникают три кнопки - Отмена, Ввод и Вставка функции. Если при вводе вы допустили ошибку, то для полной отмены ввода нажмите клавишу Esc (или кнопку Отмена в строке формул), а для исправления опечатки - клавишу Backspace. Для редактирования данных в ячейке при первоначальном вводе нельзя использовать клавиши управления курсором для перемещения по тексту, это приведет к завершению ввода, и данные будут зафиксированы. Чтобы завершить ввод данных, нужно выполнить одно из следующих действий:

  • нажать клавишу Enter - при этом активной ячейкой станет расположенная под ячейкой ввода
  • воспользоваться сочетанием клавиш Shift+Enter - активной станет ячейка, расположенная над ячейкой ввода
  • нажать клавишу Tab - активной станет ячейка, расположенная справа от ячейки ввода
  • воспользоваться сочетанием клавиш Shift+Tab - при этом активной станет ячейка, расположенная слева от ячейки ввода
  • использовать любую из клавиш управления курсором
  • щелкнуть на кнопке Ввод в строке формул - активной останется ячейка ввода
  • щелкнуть мышью на любой другой ячейке

Чаще всего для завершения ввода используется клавиша Enter. При этом активной становится ячейка, расположенная под ячейкой ввода. Можно изменить данное поведение:

  1. Выполните команду Сервис | Параметры | вкладка Правка
  2. Измените значение параметра в списке в направлении, выбрав нужное направление (Вниз, Влево, Вправо, Вверх). Чтобы после ввода ячейка оставалась активной, снимите флажок Переход к другой ячейке после ввода.

В Excel существуют возможности для ускорения ввода данных - автозаполнение и быстрый ввод значений. Эти две функции работают только в том случае, если при вводе данных в столбцы вы не пропускаете ячейки, то есть между заполненными ячейками нет пустых. Если вы пропускаете ячейку, Excel воспринимает это как завершение таблицы. При этом для новой таблицы заполнение данных из первой не происходит - для новой таблицы собирается другая информация. Автозаполнение включается, когда при вводе данных программа обнаруживает, что в данном столбце уже есть ячейки, которые содержат такие данные. При этом в активной ячейке появляется предлагаемый конец слова или фразы. Вы можете принять предложенный вариант заполнения ячейки, нажав клавишу Enter или одну из клавиш управления курсором, а можете отказаться от него, продолжив ввод дальше. При быстром вводе подходящее значение можно выбрать из списка. Для этого выделите ячейку и нажмите сочетание клавиш Alt+Стрелка вниз. Под ячейкой появится список всех текстовых значений текущего столбца. Используя клавиши управления курсором, выберите нужный вариант и нажмите Enter или просто щелкните на необходимой строке мышью.

Выделение ячеек

Перед тем как применить какую либо операцию редактирования, ячейку необходимо выделить. Если с несколькими ячейками нужно выполнить одинаковые действия, то можно выделить группу ячеек. Выделенные группы ячеек называют также диапазонами ячеек. Если вы выделите диапазон ячеек, они все будет активными, при этом вокруг ячеек возникнет окаймляющая рамка. Выделить диапазон ячеек можно следующими способами.

  • Выберите одну из ячеек и, удерживая левую кнопку мыши, перемещайте мышь до тех пор, пока нужный диапазон не будет выделен.
  • Введите в поле Имя адрес левой верхней ячейки диапазона, двоеточие и адрес правой нижней ячейки (например A1:C5) и нажмите клавишу Enter.
  • Выберите одну из ячеек таблицы и, удерживая нажатой клавишу Shift, щелкните на ячейке, расположенной по диагонали от активной.

Если нужно выделить не диапазон, а отдельные ячейки, то удерживая клавишу Ctrl, щелкайте на нужных ячейках.

Чтобы отменить выделение, щелкните мышью на любой ячейке, которая не входит в выделенный диапазон, или нажмите одну из клавиш управления курсором.

Чтобы выделить строку, щелкните на ее заголовке. Другой способ - активируйте любую ячейку строки и нажмите на клавиши Shift+Space (Пробел). Аналогично, чтобы выделить столбец, щелкните на его заголовке, или выделите любую ячейку столбца и нажмите на клавиши Ctrl+Space (Пробел)

Чтобы выделить несколько подряд идущих строк, то выделите заголовок первой строки и, удерживая нажатой клавишу Shift, щелкните на заголовке последней строки. Аналогично, чтобы выделить несколько подряд идущих столбцов, выделите заголовок первого столбца и, удерживая нажатой клавишу Shift, щелкните на заголовке последнего столбца.

Чтобы выделить несколько строк, которые расположены непоследовательно, то выделите заголовок первой строки и, удерживая нажатой клавишу Ctrl, поочередно выберите нужные заголовки строк. Аналогчино, чтобы выделить несколько столбцов, которые расположены непоследовательно, выделите заголовок первого столбца и, удерживая нажатой клавишу Ctrl, поочередно выберите заголовки нужных столбцов.

Чтобы выделить несколько несмежных диапазонов ячеек, удерживайте клавишу Ctrl при выделении диапазонов мышью. При этом активной будет первая ячейка последнего выделенного диапазона.

Для выделения всей таблицы рабочего листа нажмите кнопку, расположенную на пересечении строк и столбцов в левом верхнем углу таблицы, или воспользуйтесь комбинацией Ctrl+Shift+Пробел.

В документе есть скрытые ячейки (строки). При вставке данных заполняются и скрытые ячейки. Возможно ли чтоб при команде "вставить" заполнялись только видимые ячейки? Да, перед вставкой данных, но после выделения диапазона нужно сделать так: Правка | Перейти| Выделить | Только видимые ячейки.

Упражнение на работу с выделенным диапазоном ячеек

Выделите диапазон ячеек из двух рядов и двух столбцов (4 ячейки). Нажмите клавишу Delete, очистив ячейки от данных, если они там есть. Введите данные в первую активную ячейку диапазона и нажмите клавишу Enter. Продолжайте вводить данные в другие ячейки. Обратите внимание, что после нажатия на клавишу Enter, активной становиться одна из ячеек выделенного диапазона.

Копирование ячеек (Ввести какое-либо значение в большой диапазон)

Вам нужно ввести какое-либо значение в столбец или в большой диапазон ячеек. Вы либо долго тянете мышкой или используете копировать-вставить. Гораздо проще сделать так (для столбца):

  1. Выделите первую ячейку того диапазона, в который нужно ввести число.
  2. Щелкните в области адресов слева от строки формул и введите там адрес конечной ячейки, например A10000. Нажмите SHIFT+ENTER Таким образом Вы выделили нужный диапазон.
  3. Ведите с клавиатуры нужное число. И нажмите CTRL+ENTER. Все ячейки заполняется одинаковыми значениями

Если нужно выделить не столбец, а группу ячеек, то во втором шаге щелкните в области адресов слева от строки формул и введите там адрес выделяемого диапазон, например A1:A10000. Нажмите ENTER. Далее повторите следующие шаги.

Копирование, перемещение, вставка содержимого ячеек

Для редактирования содержимого ячеек часто используются команды Вырезать, Копировать и Вставить. С их помощью можно помещать содержимое одной ячейки в другую, быстро делать копии рабочих листов и т.д.

При вставке данных в непустую ячейку находящиеся в ней данные будут утеряны.

Копирование или перемещение содержимого ячейки можно осуществлять несколькими способами:

  • С помощью кнопок на панели инструментов Стандартная
  • С помощью команд контекстного меню, если щелкнуть на ячейке правой кнопкой мыши
  • С помощью сочетаний клавиш: Ctrl+X - вырезать; Ctrl+C - копировать; Ctrl+V - вставить.
  • Используя команды меню Правка.
  • С помощью мыши (см. ниже)

Чтобы переместить содержимое ячейки с помощью мыши нужно сделать следующее:

  1. Выделите ячейку, из которой нужно переместить данные
  2. Установите курсор в этой ячейке таким образом, чтобы он превратился в перекрестие из двух стрелок
  3. Удерживая нажатой левую кнопку мыши, переместите курсор мыши на ячейку, в которую нужно переместить данные. При этом возле курсора отображается адрес ячейки
  4. Отпустите кнопку мыши и данные будут перемещены. При этом, ячейка, в которую были внесены данные, станет активной

Копирование при помощи мыши осуществляется точно так же, только перед указанием ячейки, в которую нужно скопировать данные, необходимо нажать и удерживать клавишу Ctrl. При этом возле курсора появится знак плюс

Имейте в виду, что данные, перемещенные или скопированные из одной ячейки в другую при помощи мыши, в буфер обмена не заносятся.

Команды отмены и возврата действия

Если вы ошиблись при перемещении данных в другую ячейку, то для исправления ошибок в Excel предусмотрена возможность отмены выполненных последних действий. Вы можете отменить последнее действие следующим образом:

  • выполнив команду Правка | Отменить
  • используя сочетания клавиш Ctrl+Z
  • щелкнув на кнопке Отменить ввод на панели инструментов Стандартная

Обратите внимание, что можно отменить около 30 последних действий пользователя. Однако следует помнить, что нельзя отменить предпоследнее действие, не отменяя последнее, то есть отменять действия можно только последовательно. Чтобы отменить сразу несколько действий, щелкните на стрелке, расположенной справа от кнопки Отменить, и выберите количество отменяемых действий.

Если вы ошиблись при исправлении ошибок, то воспользуйтесь функцией Вернуть, позволяющей выполнить операцию возврата после отмены действий.

Специальная вставка

При вставке числовых или текстовых данных из других приложений часто бывает, что эти данные есть набраны другим шрифтом, имеют другой цвет и размер. В этом случае при обычной вставке возникает нарушение внешнего вида таблиц. Чтобы не тратить время на приведение данных к стандартному виду, можно использовать команду Специальная вставка. В этом случае есть возможность выбрать один из вариантов вставки данных, среди которых есть и обычный текст без форматирования. Для выполнения команды Специальная вставка выполните одно из следующих действий:

  • Используйте команду меню Правка | Специальная вставка
  • Используйте команду контекстного меню Специальная вставка
  • Щелкните на стрелке, расположенной справа от кнопки Вставить на панели инструментов Стандартная и выберите команду Специальная вставка

Удаление или добавление ячеек

Иногда бывает необходимо удалить не содержимое ячейки, а саму ячейку. Excel дает возможность удалять ячейки, исключая их из таблицы. При этом образовавшиеся на их месте пустоты закрываются в результате перемещения ячеек снизу или справа. Для удаления ячеек используется один из следующих способов:

  • Выполнить команду Правка | Удалить
  • Выбрать команду Удалить в контекстном меню ячейки

После выполнения одной из этих команд появится диалоговое окно Удаление ячеек, в котором нужно указать способ удаления. Рассмотрим варианты удаления, которые представлены в этом окне:

  • ячейки, со сдвигом влево - удаление текущей ячейки и перемещение на ее место ячейки, находящейся справа
  • со сдвигом вверх - удаление текущей ячейки и перемещение на ее место ячейки, находящейся внизу
  • строку - удаление целой строки
  • столбец - удаление целого столбца

Добавление ячеек - противоположная команда удалению. Чтобы добавить ячейку, необходимо выделить ячейку, возле которой планируется вставка, и использовать один из следующих способов:

  • Выполнить команду Вставка | Ячейки
  • Выбрать команду Добавить ячейки в контекстном меню ячейки

При этом появится диалоговое окно Добавление ячеек, в котором необходимо выбрать нужное положение переключателя:

  • ячейки, со сдвигом вправо - для добавления ячейки слева от текущей, при этом вся строка сдвинется вправо
  • строку - для добавления целой строки
  • ячейки, со сдвигом вниз - для добавления ячейки сверху от текущей, при этом весь столбец сдвинется вниз
  • столбец - для добавления целого столбца

Проверка данных при вводе

В Excel есть средство проверки данных. Оно предполагает установку пользователем типа данных и их значений для выбранной ячейки или диапазона. Когда в такие ячейки происходит ввод или значения в них изменяются, программа анализирует их в соответствии с заданными условиями и, если находит несоответствия, сообщает об этом пользователю. Ввод параметров проверки осуществляется в диалоговом окне Проверка вводимых значений, для вызова которого необходимо выполнить команду Данные | Проверка.

На вкладке Параметры этого окна устанавливаются следующие параметры

  1. Тип данных - это может быть целое число, дата, время, текст и пр.
  2. Значение - дает возможность выбора одного из критериев: больше, меньше, равно и пр.
  3. Минимум/Максимум - задает минимальное и максимальное значение.

На вкладке Сообщение для ввода можно указать сообщение, которое будет возникать при ошибочном вводе данных, а на вкладке Сообщение об ошибке - подсказку, которая будет появляться при обнаружении несоответствий.

Определение критериев ввода данных в ячейки сводит к минимуму возможные ошибки, которые могут возникнуть при заполнении таблицы. Особенно такая возможнотсь полезна, когда над таблицей работают несколько человек.

Проверка данных работает только при непосредственном вводе данных в ячейки. Если же вы скопировали в них данные из буфера при помощи маркера автозаполнения или путем перетаскивания мышью значений из других ячеек, проверка данных не сработает.

Присвоение имен ячейкам и диапазонам

Иногда очень удобно присваивать ячейкам и диапазонам ячеек отдельные имена. Эти имена впоследствии можно использовать в различных формулах, а также при выполнении перехода. Использование имени упрощает ввод формул. Назначая имена диапазонам ячеек, вы можете впоследствии вставлять их в формулы вместо заголовков столбцов и названий строк. Допустим, в книге есть необходимость использования большого количества сложных формул. Что бы не теряться и не путаться в числовых адресах ячеек и диапазонов, можно использовать их имена. Использование имени можно сравнить с адресными ссылками в Интернете. Пользователю гораздо легче запомнить название сайта, которое является понятным ему словом или словосочетанием, чем использовать ничего незначащий набор цифр - IP адрес хоста. Присвоить имя ячейке или диапазону можно несколькими способами. Они идентичны для одной ячейки и диапазона. Если при выполнении этого действия выделена ячейка, то название будет присвоено только ей, если несколько ячеек - то всему диапазону. При создании имен нужно учитывать следующее:

  • имя не должно содержать пробелов;
  • имя должно начинаться с буквы, символа подчеркивания (_) или обратного слэша (\);
  • имя не должно быть таким, как ссылка на ячейку (например, S4);
  • имя не может быть обозначено буквами R и С;
  • по умолчанию имя действительно для всех листов текущей книги.

Для присвоения имени используйте один из таких способов:

  • введите имя ячейки или диапазона в поле Имя
  • выполните команду Вставка | Имя | Присвоить

Обратите внимание, что при использовании второго способа доступно гораздо больше возможностей. Так, если вы выделяете ячейку, в которую введены текстовые данные, то программа может предложить вам присвоить ей идентичное этим данным. В окне Присвоение имени также могут отображаться имена других ячеек и диапазонов, которые используются в таблице. Это упростит выбор имени, а также позволит удалить ненужные имена.

Отдельно отметим возможность создания имени в пределах текущего листа. Если вам не нужно, чтобы заданное имя распространялось на все листы таблицы, то в поле Имя диалогового окна Присвоение имени задайте для ячейки имя вида Лист1:Имя. В результате на других листах этого имени действительно не будет.

После присвоения ячейкам и диапазонам имен поле Имя, расположенное слева от строки формул, можно использовать для быстрого перехода к элементам таблицы, а также для их быстрого выделения. Для перехода нажмите кнопку в виде стрелки справа от поля Имя и выберите нужную ячейку или диапазон из раскрывающегося списка.

Упражнение. Присвоение имен ячейкам

  1. Выделите строку, в которой записаны данные о товаре.
  2. Щелкните на поле Имя и введите в него название диапазона - Помидоры.
  3. Выделите строку, в которой записаны данные о товаре Огурцы
  4. Выполните команду Вставка | Имя | Присвоить. В окне Присвоение имени для выделенного диапазона будет предложено имя Огурцы. Нажмите кнопку ОК, чтобы подтвердить присвоение имени.
  5. Снимите выделение и снова выделите диапазон Помидоры. Убедитесь, что имя диапазона отображается в поле Имя.
  6. Нажмите кнопку в виде стрелки и выделите название диапазона Огурцы. Убедитесь, что диапазон выделен.

Создаем выпадающий список

Создаем табличку-заготовку, на той же странице выводим диапазон данных (потом это можно скрыть). Заходим на вкладку Данные и выбираем Проверка данных. В открывшемся диалоговом окне выбираем Список, и вводим диапазон значений. Жмем на Ок, и теперь в выделенной ячейке появился выпадающий список.


Форматирование таблиц

Вступление

Одни и те же данные можно по разному оформить в таблице. Для оформления можно использовать выделение определенных ячеек другим цветом, изменение размера, гарнитуры и начертания шрифта, задание другого направления надписи, увеличение высоты строк и ширины столбцов. Все эти и другие параметры оформления текста принято называть форматированием. Правильно оформленный документ облегчит его зрительное восприятие.

Форматирование строк и столбцов

По умолчанию все строки в Excel имеют стандартную высоту, а столбцы - ширину. Если текст в ячейке шире, чем ширина столбца, он заходит на ячейку, расположенную справа. Однако если в этой ячейке тоже есть данные, на экране отображается только та часть текста, который помещается в ячейке стандартной ширины. Чтобы видеть весь текст, необходимо изменить ширину столбца. Для этого сделайте следующее:

  1. Подведите указатель мыши к правой границе столбца, который нужно расширить
  2. Удерживая нажатой левую кнопку мыши, переместите указатель вправо. При этом вы сможете видеть, какой будет ширина столбца после проведенной операции
  3. Когда ширина столбца будет достаточной, отпустите кнопку мыши.

Таким же образом можно увеличить ширину сразу нескольких столбцов, расположенных рядом. Для этого выделите заголовки нужного количества столбцов, удерживая при этом клавишу Shift, и выполните операцию, описанную выше. Чтобы выделить несколько непоследовательных столбцов, выполняйте эту операцию, удерживая клавишу Ctrl.

Для изменения высоты строк выполняются те же действия, при этом используются нижние границы строк. Изменять ширину столбцов и высоту строк можно не только при помощи мыши (хотя этот способ во многих случаях является наиболее удобным). Для выполнения этой операции можно также использовать команды главного меню. Чтобы изменить высоту строки, используя команды главного меню, проделайте следующее:

  1. Выполните команду Формат | Строка | Высота
  2. В диалоговом окне Высота строки установите необходимое значение высоты строки.

Высота строки задается в пунктах от 0 до 409,5. При нулевом значении высоты строка становится скрытой. Чтобы изменить ширину столбца, используя команды главного меню, проделайте следующее

  1. Выполните команду Формат | Столбец | Ширина
  2. В диалоговом окне Ширина столбца установите необходимое значение ширины столбца

Автоподбор ширины столбцов и высоты строк

Существует также автоматическая возможность регулирования ширины столбцов и высоты строк. Это удобно, когда в таблице содержатся разные по длине строки данных. Автоподбор, как и установка ширины столбцов и высоты строк вручную, может быть осуществлен двумя способами - при помощи мыши и команд главного меню. Чтобы Excel выбрал ширину столбца автоматически, подведите указатель мыши к правой границе заголовка столбца, который нужно расширить и дважды щелкните на нем. Столбец будет расширен таким образом, чтобы в нем помещалось самое длинное значение.

Для автоматического изменения высоты строк выполняются те же действия при этом используются нижние границы заголовков строк. Чтобы автоматически подобрать ширину столбца, используя команды главного меню, необходимо выполнить следующее:

  1. Выделить заголовок столбца или группу столбцов.
  2. Выполнить команду Формат | Столбец | Автоподбор ширины. При этом программа установит ширину столбца, чтобы самая длинная запись помещалась в ячейке. Для автоматического подбора высоты строки при помощи главного меню используется команда Формат | Строка | Автоподбор высоты.

Поменять строки и столбцы местами

Скопируйте созданную в Excel таблицу. Далее выберите Правка/Специальная вставка и активируйте Транспонировать. После нажатия на ОК строки и столбцы поменяются местами.


Форматирование ячеек

Вступление

Наряду с форматированием строк и столбцов в Excel используется форматирование отдельных ячеек, что способствует более удобной работе с различными типами данных.

В большинстве случаев формат данных определяется автоматически. Чтобы это происходило корректно, разработан специальный синтаксис. Например, для ввода формул нужно используется знак =, а данные, которые программа должна воспринимать как текст - с символа ' .

Чтобы ввести отрицательное число, необходимо начать набор со знака минус - или просто заключить число в круглые скобки. При вводе положительного числа не нужно ставить перед ним знак плюс. Чтобы ввести число в денежном формате, необходимо начать набор со знака доллара ($). Для ввода процентов после числа наберите символ процента (%). Чтобы ввести простую дробь, наберите число в формате Целая часть Пробел Числитель/Знаменатель. Целую часть нужно вводить всегда, даже если она равна нулю, так как при ее отсутствии Excel может воспринять данные как дату. При вводе десятичной дроби используйте запятую для отделения целой и дробной частей. Чтобы ввести данные в экспоненциальном виде, используйте символ Е или е. Например, чтобы ввести число два в степени пять, наберите 2е5.

В Excel значения, отображаемые на экране и сохраняемые в памяти, могут различаться.

Выравнивание содержимого ячеек

Вы уже знаете, что по выравниванию можно определить, в каком формате представлены данные в ячейке.

  • формат Числовой - данные выравниваются по правому краю. К числовым данным могут быть отнесены символы от нуля до девяти.
  • формат Текстовый - содержимое ячейки будет выровнено по левому краю.
  • формат Денежный - выравнивание по правому краю ячейки
  • формат Финансовый - выравнивание по центру.

Помимо этого существует возможность выбирать тип выравнивания отдельно для каждой ячейки. Это может быть очень удобным, если, например, вам нужно отформатировать заголовок над таблицей. В этом случае вы можете использовать выравнивание по центру. Выравнивание данных в ячейке осуществляется при помощи вкладки Выравнивание диалогового окна Формат ячеек. Для вызова этого окна выполните следующее:

  1. Выделите ячейку или диапазон ячеек, выравнивание которых нужно изменить.
  2. Выполните команду Формат Ячейки или щелкните на ячейке правой кнопкой мыши и выберите команду Формат ячеек в контекстном меню.
  3. Перейдите на вкладку Выравнивание.

Рассмотрим возможности форматирования, представленные на этой вкладке. Список по горизонтали служит для установки горизонтального выравнивания. С его помощью можно установить следующие значения:

  • по значению - текст выравнивается по левомукраю, а числа - по правому
  • по левому краю (отступ) - данные в ячейке выравниваются относительно ее левого края, отступ от левого края устанавливается при помощи изменения значения параметра отступ
  • по центру - данные в ячейке выравниваются по центру ячейки
  • по правому краю (отступ) - данные в ячейке выравниваются относительно ее правого края, отступ от правого края устанавливается при помощи изменения значения параметра отступ
  • с заполнением - все пространство ячейки заполняется повторяющимися текстовыми или числовыми символами, которые были в ячейке на момент окончания ввода
  • по ширине - данные в ячейке выравниваются одновременно по левому и правому краям, при этом текст разбивается таким образом, чтобы его ширина не была больше ширины ячейки и, соответственно, может быть изменена высота ячейки
  • по центру выделения - данные в ячейке выравниваются по центру выделенного диапазона ячеек. Такое выравнивание может быть установлено только для диапазона ячеек, который нужно заранее выделить
  • распределенный (отступ) - данные в ячейке равномерно распределяются по ширине ячейки в зависимости от ширины отступа, который устанавливается при помощи параметра отступ.

Список по вертикали служит для установки горизонтального выравнивания. С его помощью можно установить следующие значения:

  • по верхнему краю - данные в ячейке выравниваются по верхнему ее краю
  • по центру - по центру ячейки
  • по нижнему краю - по нижнему краю ячейки
  • по высоте - по верхнему и нижнему краям ячейки
  • распределенный - данные в ячейке равномерно распределяются по ширине ячейки в зависимости от ширины отступа, который устанавливается при помощи параметра отступ.

Также можно изменять выравнивание содержимого ячеек при помощи кнопок панели инструментов Форматирование.

При помощи области Отображение вкладки Выравнивание диалогового окна Формат ячеек позволяет также установить дополнительные варианты отображения данных в ячейке:

  • переносить по словам - данные в ячейке отображаются в несколько строк, если ширина ячейки меньше, чем ширина данных в ней
  • объединение ячеек - данные в двух или более ячейках могут быть объединены в одну
  • автоподбор ширины - форматирование данных в ячейке будет изменено так, чтобы они помещались в столбце

Если установлен флажок автоподбор ширины, то при изменении ширины столбца размер символов также будет изменен.

Вращение текста

Чтобы таблица выглядела красиво, можно устанавливать для заголовков столбцов разное направление текста - вертикальное или под выбранным углом. Данные настройки находятся на вкладке Выравнивание диалогового окна Формат ячеек.

Градус поворота текста задается в области Ориентация. Для вращения текста в ячейке можно:

  • установить числовое значение в поле градусов
  • повернуть стрелку направления в поле Надпись, при этом в поле градусов появится соответствующее значение

Добавление границ и заливки

Для оформления таблицы часто используются границы и заливка заливка ячеек. Параметры добавления границ располагаются на вкладке Граница диалогового окна Формат ячеек. Границы могут быть следующих типов:

  • внешние - будет обведен весь диапазон ячеек по контуру
  • внутренние - все внутренние линии выделенных ячеек будут обведены
  • отдельные - будут обведены лишь указанные линии

Можно выбрать несколько вариантов таких линий, нажав соответствующую кнопку. При этом в окне Надпись будет показана создаваемая таблица. Чтобы убрать одну из линий, нажмите соответствующую кнопку еще раз. Также необходимо выбрать, как будет выглядеть линия, в списке Тип линии. Можно определить стиль линии, ее толщину и цвет. Параметры добавления заливки находятся на вкладке Вид диалогового окна Формат ячеек. Можно выбрать цвет заливки из предложенной палитры, а также узор заливки из списка Узор. Сочетание заданного цвета и узора показано в поле Образец. Изменять параметры границ и заливки можно также при помощи соответствующих кнопок панели инструментов Форматирование.

Изменение шрифтов

Чтобы получить доступ к настройкам шрифта нужно:

  • выделить ячейку или диапазон, выполнить команду Формат | Ячейки и перейти на вкладку Шрифт
  • вызвать контекстное меню щелчком правой кнопкой мыши на выделенной ячейке или диапазоне, выбрать строку Формат ячеек и перейти на вкладку Шрифт.

При помощи вкладки Шрифт диалогового окна Формат ячеек можно задавать цвет текста, изменять начертание шрифта, устанавливать размер и цвет символов. Изменять параметры шрифта можно также при помощи соответствующих кнопок панели инструментов Форматирование.

Также можно изменять параметры шрифта с помощью панели Форматирование. На нее вынесены основные параметры форматирования шрифта и другие часто используемые команды.

Сохранение начальных нулей при вводе данных

При вводе чисел с начальными нулями, например 007, Excel удаляет из числа начальные нули. В результате число 007 превращается в 7. Это может привести к ошибкам в макросах, если начальные нули играют определенную роль. По умолчанию, Excel считает начальные нули лишними. Чтобы исправить это поведение, нужно, чтобы данные воспринимались как текст, а не как числа:

  • Выделите необходимые ячейки, в которых будут использоваться числа с начальными нулями.
  • Щелкните на ячейках правой кнопкой мыши и выберите в контекстном меню команду Формат ячеек | вкладка Число.
  • Вместо формата Общий, используемого при работе как с числами, так и с обычным текстом, следует выбрать формат Текстовый. Теперь числовые данные будут восприниматься как обычный текст, что позволит использовать начальные нули.

Предотвращение преобразования чисел в формат даты/времени

Аналогичная проблема возникает при вводе некоторых чисел, которые преобразовываются в даты. Измените формат ячеек на текстовый, как было указано выше перед работой с такими числами.


Рабочая книга

Вступление

Документы программы Microsoft Excel называются рабочими книгами. Каждая книга представляет собой отдельный файл с расширением XLS. Когда вы открываете окно программы Excel, то в нем автоматически создается рабочая книга. Ячейки таблицы являются элементами рабочей книги. Если в окне Excel не открыта ни одна книга, то большинство кнопок на панелях инструментов и команд главного меню неактивны. Книги состоят из одного или нескольких рабочих листов.

Чтобы пользователь мог узнать данные по рабочей книге (что представляет собой данная рабочая книга, кто ее автор, кто ее редактировал, а также задать ключевые слова и сделать заметки), то можно задать эти свойства. Выполните следующие действия:

  1. Выберите в меню Файл | Свойства | вкладка Документ
  2. Заполните соответствующие поля Название, Тема, Автор, Учреждение, Ключевые и так далее. Обратите внимание, что некоторые поля уже заполнены по умолчанию. Вы можете изменить их при необходимости.
  3. Если установить флажок Создать рисунок для предварительного просмотра, то программа создаст изображение листа книги в момент сохранения документа. Это изображение, а также все введенные на вкладке Документ данные будут показаны в окне папки при выделении файла.

Кроме того, на вкладке Статистика представлена информация о том, кто и когда вносил изменения в книгу, а так же общее время правки; на вкладке Состав видна структура документа. Здесь отображаются названия листов документа; на вкладке Прочие задают дополнительные пользовательские свойства. Здесь можно указать рабочую группу, имя редактора и другие сведения. Для ввода дополнительных пользовательских свойств сделайте следующее: выберите вид пользовательского свойства из списка Название; выберите тип значения свойства из раскрывающегося списка, введите значение в поле Значение и нажмите кнопку Добавить.

Во время работы часто возникает необходимость просматривать рабочие книги в разных режимах. Например, нужно увидеть, как она будет выглядеть перед печатью и т. д. В программе предусмотрено несколько режимов просмотра (меню Вид). По умолчанию используется режим Обычный.

  • Режим Обычный - стандартный режим, в котором обычно работают пользователи.
  • Режим Разметка страницы позволяет настраивать область печати и разрывы страниц. Область печати отображается белым цветом, автоматические разрывы страниц - пунктиром, а вставленные пользователем разрывы страницы - непрерывными линиями. Такой режим используется при работе с документами, предназначенными для вывода на печать.
  • Режим Во весь экран используется для увеличения рабочей области. При этом скрываются панель инструментов, строка состояния и другие элементы интерфейса. Данный режим используется опытными пользователями, которые не пользуются панелью инструментов, а используют в своей работе клавиатуру. Для возврата к режиму Обычный нажмите кнопку Вернуть обычный режим или выполните команду Вид | Во весь экран.


Листы

Каждый лист является самостоятельным элементом, и с ним можно выполнять различные действия: переименовывать, удалять, перемещать, копировать.

Вы можете перемещаться между листами при помощи сочетаний клавиш. Для перехода к следующему листу воспользуйтесь комбинацией Ctrl+Page Down, а для возврата к предыдущему - Ctrl+Page Up.

По умолчанию книга Excel состоит из трех листов - Лист1, Лист2 и Лист3. При большом количестве листов удобнее присвоить им другие имена. Для переименования листа щелкните правой кнопкой мыши на ярлыке нужного листа и выберите пункт Переименовать. Название листа может содержать от 1 до 31 символов, при этом не допускаются знаки ? * \ / [ ]. Также можно это сделать через команду Формат | Лист | Переименовать.

Если вы постоянно работаете с документами одного типа, то вам, возможно, будет удобно, если все создаваемые документы будут содержать не три, а большее количество листов. Для этого необходимо изменить параметры создания рабочих книг по умолчанию:

  1. выберите в меню Сервис | Параметры | вкладка Общие
  2. Измените значение в строке Листов в новой книге

Для добавления листа в книгу выполните команду Вставка | Лист или щелкните на ярлыке листа правой кнопкой мыши, выберите в контекстном меню пункт Добавить, и выберите в открывшемся окне Вставка - значок Лист. Ярлык нового листа появится слева от закладки листа, активного в момент создания нового. Количество листов, которые могут храниться в одной рабочей книге, не ограничено и определяется объемом оперативной памяти компьютера. Если вам нужно добавить в книгу сразу несколько листов, то:

  1. Нажмите и удерживайте клавишу Shift.
  2. Выделите необходимое число ярлыков листов. Если вы работаете с книгой, которая была создана в Excel по умолчанию, то можете выделить все три ярлыка листа.
  3. Отпустите клавишу Shift.
  4. Далее повторить шаги по добавлению листа, описанные выше

Выбор листов

Для решения некоторых задач можно выделять отдельные листы. Например, для выделения отдельных листов нажмите и удерживайте клавишу Ctrl и мышкой выберите нужные листы. Для выделения группы идущих вместе листов нажмите и удерживайте клавишу Shift и мышью выберите любой лист справа или слева от выделенного листа. Чтобы выделить все листы, нужно щелкнуть на любом ярлычке правой кнопкой мыши и выбрать команду Выделить все листы. Обратите внимание, что при выделении нескольких листов в заголовке окна появляется надпись [Группа].

Одновременный ввод данных на нескольких листах

Если вы используете одинаковые данные на разных листах, то можно осуществить одновременный ввод данных, экономя свое время. Предположим, вам нужно занести данные о сотрудниках в трех листах. Вам придется несколько раз вводить одни и те же данные, но можно сделать по другому. Чтобы одновременно ввести данные в одних и тех же ячейках нескольких листов, нужно выделить ярлычки требуемых листов. После этого можно вводить данные.

Оглавление книги Excel

Хотите автоматически получить список всех листов Вашей книги в виде гиперссылок и переходить на нужный лист одним щелчком? Выберите в меню Сервис - Макрос - Редактор Visual Basic (Tools - Macro - Visual Basic Editor). В открывшемся окне редактора создайте новый пустой модуль (меню Insert - Module) и скопируйте туда текст этого макроса:

Sub SheetList()
   Dim sheet As Worksheet
   Dim cell As Range
   With ActiveWorkbook
      For Each sheet In ActiveWorkbook.Worksheets
         Set cell = Worksheets(1).Cells(sheet.Index, 1)
         .Worksheets(1).Hyperlinks.Add anchor:=cell, Address:="", SubAddress:="'" & sheet.Name & "'" & "!A1"
         cell.Formula = sheet.Name
      Next
   End With
End Sub

Закройте редактор Visual Basic и вернитесь в Excel. Добавьте в книгу чистый лист и поместите его на первое место. Затем откройте меню Сервис - Макрос - Макросы. Найдите там созданный макрос SheetList и запустите его на выполнение. Макрос создаст на первом листе книги список гиперссылок с названиями листов. Щелчок по любой из них переместит Вас на нужный лист.

Источник: http://www.planetaexcel.ru/tip.php?aid=49


Условное форматирование

Вступление

Условное форматирование - одна из очень удобных функций Excel. Условное форматирование применяется к данным тогда, когда они удовлетворяют определенным критериям. Предположим, в таблице нужно выделить числа до 100 одним цветом, а свыше 100 другим цветом. Используя условное форматирование, Excel отформатирует числа по заданным параметрам.

Для применения условного форматирования необходимо проделать следующее:

  • Выделите диапазон ячеек или отдельные ячейки, к которым будет применено условное форматирование
  • Выполните команду Формат | Условное форматирование
  • В диалоговом окне Условное форматирование установите необходимые параметры форматирования

Пример

Создайте рабочую книгу и заполните несколько ячеек произвольными числовыми данными в диапазоне от 0 до 100. Выделите заполненные ячейки. Не снимая выделение выполните команду Формат | Условное форматирование. В диалоговом окне Условное форматирование выберите в первом поле строку значение, во втором поле строку меньше, а в третье поле введите значение 50. Далее нажмите на кнопку Формат, чтобы настроить формат ячейки, который будет устанавливаться при условном форматировании. Измените цвет шрифта на зеленый. Нажмите кнопку ОК, чтобы подтвердить заданные параметры условного форматирования. Затем нажмите на кнопку А также, чтобы задать второе условие. Повторите предыдущие шаги, только на этот раз выберите параметры больше 50 и выберите отличный от зеленого цвет шрифта. Если все сделано правильно, то числа в таблице будут разукрашены в соответствии с вашими настройками.

Автоматическое форматирование

Функция Автоформат позволяет быстро создавать красиво оформленную таблицу. Для этого выполните следующее:

  1. Выделите нужный диапазон ячеек
  2. Выполните команду Формат | Автоформат.

В Excel содержится 17 основных вариантов автоматического форматирования для разных видов таблиц. Выберите нужный вам вариант. Если вы хотите изменить какой нибудь параметр форматирования таблицы, воспользуйтесь кнопкой Параметры. Дополнительные параметры появятся под окнами стилей. Вы можете отключать некоторые из параметров - формат шрифта, чисел, выравнивание, узор и пр.


Стили и шаблоны

Вступление

Очень часто, процесс форматирования занимает достаточно много времени. Один из эффективных способов упростить форматирование - использовать стили и шаблоны.

Стили представляют собой набор атрибутов форматирования (начертание и размер шрифта, выравнивание, узоры и т.п.), которые при использовании действуют на ячейку или диапазон ячеек одновременно. Задав один раз необходимые параметры, можно пользоваться ими все время, в разных рабочих книгах. В Excel имеется несколько заготовленных стилей, которые наиболее часто используются. По умолчанию Excel использует стиль Обычный. Также в Excel доступно еще несколько основных стилей:

  • Финансовый - числовой формат, используются разделители разрядов и два десятичных знака
  • Финансовый [0] - числовой формат, используются разделители разрядов, числа округляются до целого
  • Денежный - числовой формат, используются разделители разрядов, два десятичных знака и символ валюты
  • Денежный [0] - числовой формат, используются разделители разрядов и символ валюты, числа округляются до целого
  • Процентный - числовой формат, используется символ процентного представления чисел, десятичные знаки не используются

Чтобы применить к ячейке или диапазону ячеек стиль, необходимо выполнить следующее:

  1. Выделить ячейку или диапазон
  2. Выполнить команду Формат | Стиль
  3. Выбрать стиль из раскрывающегося списка Имя стиля

Если вы часто используете стили при оформлении таблиц, то можете вынести на панель инструментов Форматирование раскрывающийся список Стиль

Изменение настроек стандартных стилей

Для каждого стандартного стиля можно изменить те или иные параметры. В этом случае при назначении стиля будут использоваться параметры форматирования с учетом внесенных вами изменений. Для изменения одного из стандартных стилей проделайте следующее:

  1. Выполните команду Формат | Стиль
  2. Выберите нужный стиль из раскрывающегося списка Имя стиля
  3. Установите или снимите флажки в области Стиль включает
  4. Нажмите кнопку Изменить, откроется диалоговое окно Формат ячеек, при помощи которого можно задать все необходимые параметры форматирования, - от границ и заливки до выравнивания и настроек шрифта
  5. Нажмите кнопку ОК, чтобы подтвердить выбранные в окне Формат ячеек настройки. Нажмите кнопку ОК в окне Стиль

Пользовательские стили

Вполне возможно, что вы не найдете среди встроенных стилей именно то, что нужно вам. В этом случае вы можете создать свой собственный пользовательский стиль. Создавать стили можно двумя способами: на основе оформленной ячейки или устанавливая все настройки форматирования вручную. Если у вас есть данные, оформление которых для вас является образцом, можно создать стиль на их основе. В этом случае вы сможете применять его в любой таблице, с которой работаете. Для создания стиля на основе отформатированной ячейки сделайте следующее:

  1. Выделите ячейку, которая служит образцом
  2. Выполните команду Формат | Стиль
  3. В диалоговом окне Стиль укажите имя нового стиля. Проверьте, установлены ли все флажки в области Стиль включает (по примеру)
  4. Нажмите кнопку Добавить
  5. Нажмите кнопку ОК, чтобы подтвердить создание нового стиля

Для создания стилей на основе отформатированной ячейки используйте однуячейку, а не диапазон. Дело втом, что ячейки диапазона могут иметь разное форматирование и для нового стиля будут использованы только те элементы оформления, которые являются общими для всех выделенных ячеек.

Для создания стиля путем выбора параметров форматирования проделайте следующее:

  1. Выполните команду Формат Стиль
  2. В диалоговом окне Стиль укажите имя нового стиля
  3. Нажмите кнопку Изменить, откроется окно Формат ячеек, в котором вы можете задать все необходимые параметры от границ и заливки до выравнивания и настроек шрифта
  4. Нажмите кнопку ОК, чтобы подтвердить выбранные настройки в окне Формат ячеек
  5. Нажмите кнопку Добавить, чтобы подтвердить добавление нового стиля

Объединение стилей

В Excel стили сохраняются только в рамках рабочих книг, что не очень удобно. Однако часто бывает, что пользовательские или же стандартные стили с измененными параметрами необходимо использовать в других книгах. В этом случае нужно объединить стили. Если нужно перенести стиль из одной рабочей книги в другую, выполните следующее:

  1. Откройте обе книги и перейдите в ту, в которую нужно скопировать стиль
  2. Выполните команду Формат | Стиль
  3. В диалоговом окне Стиль нажмите на кнопку Объединить
  4. Выберите нужную книгу из списка

При объединении стилей в текущую книгу будутскопированы все стили из исходной книги. Копировать стили по одному невозможно.

Шаблоны

Еще один способ упростить процедуру форматирования - использовать шаблоны. В отличие от стиля, кроме видов форматирования, шаблон обычно включает в себя определенные участки текста, которые пользователь просто дополняет своими данными. Среди шаблонов, входящих в стандартную поставку - шаблоны для создания отчетов, счетов, балансов и др. Использование шаблонов может существенно ускорить подготовку документов различных типов.

По умолчанию используется шаблон Normal. Чтобы получить доступ к другим шаблонам, нужно:

  1. Выполнить команду Файл | Создать
  2. В области задач Создание книги выбрать ссылку Шаблоны на моем компьютере

Пользоваться шаблонами очень просто - достаточно лишь выбрать нужный из диалогового окна Шаблоны. В каждом шаблоне есть подсказки по использованию. Это может быть короткая инструкция в конце документа или же надписи типа «Здесь впишите название Вашей фирмы» в самом тексте. Все подобные подсказки необходимо заменить соответствующим текстом. В зависимости от ваших потребностей шаблоны можно использовать целиком или же какую нибудь их часть. Шаблоны, с которыми вы часто работаете, не нужно каждый раз искать по ссылке Шаблоны на моем компьютере - программа сама вынесет их в область задач Создание книги.

Для создания документа на основе шаблона нужно использовать область задач Создание книги. Если же открыть шаблон, выполнив команду Файл | Открыть, изменения, которые вывносите,будутзаписываться в сам шаблон, а не в документ, созданный на его основе.

Создание пользовательских шаблонов

Благодаря шаблонам можно сэкономить очень много времени. Например, если вы постоянно общаетесь с какой нибудь организацией и каждый раз вводите стандартное приветствие, реквизиты и т. д., удобно создать собственный шаблон на основе любого стандартного. Для этого проделайте следующее

  1. Откройте рабочую книгу, которая будет служить шаблоном
  2. Выполните команду Файл | Сохранить как
  3. Введите имя шаблона
  4. Из списка Тип файла выберите пункт Шаблон. По умолчанию Excel предложит вам сохранить файл в папке Шаблоны , однако вы можете выбрать другую папку. При создании шаблона заносите в него только общую информацию, которая нужна вам в каждом документе, основанном на таком шаблоне. Например, не стоит при разработке шаблона для создания отчета за месяц набирать данные по дням недели, иначе каждый раз, когда вы захотите воспользоваться своим шаблоном, вам придется удалять их и вносить новые.
  5. Нажмите кнопку Сохранить. Лучше сначала создайте шаблон, а взяв его за основу, приступайте к текущим делам.

Если необходимый шаблон отсутствует на компьютере пользователя, и компьютер подключен к Интернету, то можно поискать шаблон на сайте Microsoft. Для этого существует ссылка Шаблоны на узле Office Online. Шаблоны могут облегчить работу с книгами определенного типа: счетами, отчетами и пр.


Формулы

Одно из основыных свойств таблиц - способность хранить в ячейках не только статические данные, но и формулы, по которым программа может вычислять и выводить результат. Строка формул располагается между панелями инструментов и заголовками столбцов, справа от поля Имя В ячейке отображается результат вычисления, а в строке формул - сама формула. Строка формул представляет собой поле, в котором отображается содержимое активной ячейки. Если в активную ячейку введена формула (выражение, которое начинается со знака равенства), то в строке формул вы увидите введенное в нее выражение. При этом в самой ячейке отображается не формула, а результат вычисления по ней.

Если вы случайно удалили строку формул, то ее легко восстановить. Выбираем в меню Сервис | Параметры | Вид | Отображать строку формул.

Microsoft Excel содержит широкий набор средств для обработки числовых значений по заданным формулам. Программа позволяет работать с очень сложными формулами и включает в себя сотни функций, которые помогают вести разнообразные дайствия: бухгалтерские расчеты, построение баз данных и т. д. Все формулы начинаются со знака равно, после которого располагается выражение, состоящее из разного типа констант встроенных функций программы, а также знаков арифметических, текстовых и логических операций. Самым простым примером формулы может служить выражение =1+2. Формула может содержать ссылку на ячейку (ее адрес) и на диапазон ячеек. При записи формулы используются следующие знаки математических вычислений:

  • + - сложение
  • - - вычитание
  • * - умножение
  • / - деление
  • ^ - возведение в степень
  • % - вычисление процента
  • < - выполнение условия «меньше»
  • > - выполнение условия «больше»
  • <= - выполнение условия «меньше или равно
  • >= - выполнение условия «больше или равно»
  • <> - выполнение условия «не равно»

Операции вычисления по заданной формуле выполняются слева направо. При этом в первую очередь выполняются операции возведения в степень, затем умножения и деления, после них - сложения и вычитания. Если необходимо изменить порядок вычислений, то используйте круглые скобки.

Создание простой формулы

Составим простую формулу.

  1. Выделите любую ячейку, в которую будет введена формула
  2. Поставьте знак равенства
  3. Введите формулу, используя вместо чисел ссылки на ячейки. Например, =A1+A5. В этом случае при последующем изменении любого из чисел в выбранных ячейках, программа автоматически изменит результаты вычислений по формуле, используя изменившиеся данные
  4. Нажмите на клавишу Enter после ввода формулы. В ячейке отобразится результат вычислений по формуле

При составлении формул можно не вводить адреса ячеек вручную. После ввода знака = можно просто щелкнуть на нужной ячейке, при этом вокруг выделенной ячейки появится пунктирная рамка, а ее адрес появится в ячейке, в которую осуществляется ввод формулы.

По умолчанию, при использовании формул в ячейках отображаются не сами формулы, а результат вычислений по ним. Сама формула видна в строке формул, там же ее можно редактировать. Такжем можно добиться того, чтобы в ячейке отображалась сама формула. Для этого выполните следующие действия

  1. Выполните команду Сервис | Параметры | вкладка Вид
  2. В группе настроек Параметры окна установите флажок Формулы. Нажмите кнопку OK, чтобы подтвердить изменения.
  3. Теперь в ячейках будут отображаться сами формулы, а не результаты вычислений по ним

Также можно использовать сочетание клавиш Ctrl+~, что позволяет быстро переключаться между двумя режимами.

Копирование формул

Вводить формулу каждый раз довольно утомительно, особенно если все формулы одинаковые, именно поэтому есть возможность копировать формулы из одной ячейки в другую. При этом программа анализирует расположение ячейки, в которую перенесена формула, и изменяет ссылки соответствующим образом. Копирование формул осуществляется таким же образом, как и копирование данных:

  1. Выделите ячейку, в которой находится нужная формула
  2. Выполните команду Правка | Копировать
  3. Выделите ячейку или диапазон ячеек, в которую нужно скопировать формулу
  4. Выполните команду Правка | Вставить

Вы также можете использовать любой другой способ копирования данных, например, при помощи сочетания клавиш Ctrl+C контекстного меню или соответствующей кнопки на панели инструментов Форматирование.

Если ячейки, в которые необходимо скопировать формулу, находятся рядом с ячейкой, в которой располагается исходная формула, можно также воспользоваться командой автоматического заполнения, чтобы ускорить копирование данных. Для выполнения команды автозаполнения выполните следующее.

  1. Выделите ячейку, в которой находится нужная формула, а также ту (или те), в которую (или в которые) вы хотите скопировать формулу.
  2. Выполните команду Правка | Заполнить
  3. Выберите направление копирования в зависимости от расположения ячеек. Например, если исходная ячейка расположена слева от той, в которую нужно осуществить копирование, выберите команду Вправо. В качестве альтернативы выполнению команд главного меню вы можете использовать сочетания клавиш Crtl+D для копирования формул в направлении Вниз и Ctr+R - в направлении Вправо.

Поиск ошибок в формулах

Если формула составлена правильно, Excel просчитает введенное выражение и представит результат. Однако если выражение содержит ошибку, может произойти сбой, о чем программа сообщит пользователю. Сообщение об ошибке всегда начинается со знака решетка (#). Оно выводится в данной ячейке вместо самой формулы или результата. При этом возле ячейки появится значок восклицательного знака, при наведении указателя на который появится информация об ошибке. При щелчке на этом значке вы получите доступ к меню, при помощи которого можно получить справку об ошибке, исправить формулу, просмотреть, на каком этапе возникла ошибка и т. д.

Ошибки могут быть следующих типов:

  • #Имя? - ошибка при наборе имени (например, СУММА (A2))
  • ###### - число дата при отображении не помещаются в ячейке
  • #ДЕЛ/0! - деление на ноль, обратите внимание, что пустые ячейки также считаются нулями (например, =D3/0);
  • #Н/Д - неопределенные данные, может использоваться пользователем для индикации ячеек, куда еще не введены данные
  • #ЗНАЧ! - используется аргумент недопустимого типа
  • #ПУСТО! - используется ошибочная ссылка на ячейку или диапазон, например, задано пересечение двух областей, которые не имеют общих ячеек
  • #ССЫЛКА! - при ссылке на ячейку указывается недопустимый адрес, ошибка может возникнуть, например, при копировании формул
  • #ЧИСЛО! - в функции с числовым аргументом используется неприемлемый для Excel аргумент

Если Excel обнаруживает в формуле ошибку, которую можно исправить автоматически, выдается соответствующее сообщение с предложением изменить формулу. Предложение можно принять или отвергнуть.

Несмотря на то что Excel автоматически контролирует формулы на наличие ошибок, проверяйте формулы самостоятельно. Даже если программа не выдает сообщение об ошибке, результат может оказаться неправильным, если в формуле ошибка (дана неправильная ссылка на ячейку, использовано другое арифметическое действие и т.д.).

Как прописать формулу, чтобы при отрицательном значении ячейка имела красный цвет, а при положительном - зеленый? Есть два способа. Первый из них заключается в следующем: написав в ячейке формулу, щелкните по ней, затем войдите в меню Формат|Условное форматирование. В появишемся окне выставите Условие 1 - значение больше 0. Затем щелкните по кнопке Формат и выберите как отобржать ячейку. После этого щелкните по кнопке А также и пропишите Условие 2 точно так, как первое, с той лишь разницей, что вместо больше укажите меньше.Существует и другой способ: выделите ячейку с формулой, затем, щелкните по ней правой кнопкой и выберите пункт Формат ячеек. На вкладке Все форматы в поле Тип введите следующее значение: [Зеленый]# ##0,00;[Краснный]-# ##0,00, нажмите Enter.

Абсолютные ссылки

Как вы уже знаете, формула может содержать ссылку на ячейку (ее адрес) и на диапазон ячеек. Причем использование в формулах адресов ячеек, а не числовых данных, в большинстве случаев является предпочтительным, так как в этом случае при изменении данных в ячейках автоматически изменяется результат вычисления по формуле. Формулы, как и любые иные данные в Excel, можно копировать в другие ячейки. При этом адреса ячеек, внесенные в формулы, автоматически изменяются. Обычно это очень удобно, так как, копируя формулу пользователи хотят получить в другой ячейке измененный в соответствии с ее положением результат. Такие ссылки называются относительными. Они применяются в Excel по умолчанию. В программе также используются особые ссылки, которые не изменяются при копировании формул в другие ячейки - абсолютные ссылки. Они позволяют сохранить адрес определенной ячейки в формуле неизменным, даже если расположение ячейки изменяется. Для записи абсолютной ссылки используется знак доллара Этот знак ставится и перед названием столбца и перед номером ячейки, например, $А$4. Если знак доллара поставить только перед названием столбца или номером ячейки, такая ссылка будет смешанной, то есть в первом случае абсолютным будет только столбец, а номер строки - относительным, а во втором - ссылка на номер строки будет абсолютной, а на название столбца - относительной.

Присвоение имен формулам

Вы уже знаете, что для ускорения ввода формул их можно копировать. Такой способ эффективен, когда формулы расположены на листе рядом. Но если таблица содержит большое количество формул и они находятся в разных местах рабочей книги, то на поиск формулы для копирования может потребоваться больше времени, чем на ее ввод вручную. Поэтому присвоение имен формулам - более удобное средство ввода повторяющихся формул.

Чтобы присвоить имя формуле, выполните описанные ниже действия.

  1. Выберите в меню Вставка | Имя | Присвоить.
  2. В окне Присвоение имени наберите формулу в поле Формула.
  3. Введите имя формулы в поле Имя. Нажмите кнопку ОК, чтобы подтвердить присвоение имени формуле.

Для удаления имени формулы нажмите кнопку Удалить в окне Присвоение имени.

Редактирование имен

Если в вашей таблице используются имена, то вам будет гораздо проще исправлять формулы в случае изменения каких либо данных. Представьте, что таблица содержит несколько формул, в которых используются данные ячейки. В последствии эти данные были перенесены в другую ячейку или вообще утратили актуальность. Если в формулах была использована ссылка на ячейку, то заменить адреса в формулах будет сложно, особенно если делать это вручную (о возможном решении проблемы см. ниже про вставку имен). Если же вместо ссылки было использовано имя, то достаточно изменить адрес ячейки, которой оно присвоено.

  1. Выполните команду Вставка | Имя | Присвоить.
  2. В окне Присвоение имени выберите нужное имя из списка.
  3. В поле Формула измените адрес ячейки или диапазона на новый.

Упражнение. Изменение адреса ячейки, для которой выбрано имя

Откройте рабочую книгу Овощи. Допустим созданное нами имя диапазона используется на других листах таблицы. По некоторым причинам нам больше не нужно включать в этот диапазон ячейку F4, содержащую данные о средней стоимости продуктов. Чтобы не изменять адреса вручную, исправим адрес диапазона для заданного имени.

  1. Выполните команду Вставка | Имя | Присвоить.
  2. В окне Присвоение имени выберите имя Огурцы из списка
  3. Установите курсор в поле Формула. При этом диапазон ячеек, которому присвоено имя, будет взят в пунктирную рамку.
  4. Измените адрес диапазона =Лист1:$B$4:$F$4 на =Лист1:$В$4:$Е$4. Нажмите кнопку ОК, чтобы подтвердить изменение адреса имени.
  5. Нажмите кнопку в виде стрелки и выделите название диапазона Огурцы. Убедитесь, что теперь выделен новый диапазон.

Вставка имен в формулы

Конечно, хорошо, если при работе с таблицей с самого начала использовались имена. Но что делать, если есть таблица, в формулах которой были ведены адреса ячеек, а не их имена? Даже в этом случае вручную вносить изменения в формулы необя зательно. Excel позволяет автоматически вставить во все формулы вместо ссылок на ячейки их имена, которые были присвоены после составления формул.

  1. Выполните команду Вставка | Имя | Применить.
  2. В диалоговом окне Применение имен выберите из списка имена, которыми вы хотели бы заменить адреса ячеек в формулах.
  3. Нажмите кнопку OК, чтобы подтвердить изменения.


Функции

В состав Excel входят встроенные функции, которые облегчают запись формул. Например, есть функция для вывода на экран наибольшего и наименьшего числа из заданного диапазона (функции МАКС и МИН). Самый простой способ использования функций - использовать поле Имя, расположенного в левой части строки формул. При вводе или редактировании формулы оно заменяется кнопкой, на которой отображена последняя использовавшаяся функция. Если щелкнуть на треугольнике, расположенном рядом с именем последней использовавшейся функции в правой части поля Имя, появится список из 10 последних использовавшихся функций. Чтобы получить доступ к другим функциям, выберите строку Другие функции. Если вы еще не использовали функции, в этом списке будут отображены наиболее часто используемые функции. Они внесены по умолчанию в поле Имя. Выбор функции осуществляется при помощи диалогового окна Мастер функций, которое позволяет строить сложные формулы с несколькими функциями, не вводя при этом функции с клавиатуры. Вызвать это окно можно одним из следующих способов:

  • нажать кнопку Вставка функции, расположенную возле строки формул
  • выбрать строку Другие функции в раскрывающемся списке поля Имя
  • выполнить команду Вставка | Функция
  • воспользоваться сочетанием клавиш Shift+F3

Чтобы вставить функцию в формулу, нужно:

  1. В диалоговом окне Мастер функций щелкните на нужной функции в списке Выберите функцию. Если нужной функции нет в списке, выберите строку Полный алфавитный перечень в списке Категория и найдите функцию по алфавиту
  2. Если вы не знаете название функции, введите короткое описание того, что вы хотите сделать, в поле Поиск функции. Например, если нужно найти сумму чисел, введите в это поле найти сумму. При выборе функции из списка в нижней части окна появится ее короткое описание
  3. Выбрав функцию, нажмите кнопку ОК. Откроется диалоговое окно Аргументы функции. Поля для ввода аргументов могут быть обязательными и необязательными для заполнения. Первые выделены полужирным шрифтом. При вводе аргументов в нижней части окна будет выводиться текущий результат функции и всей формулы.

При вводе ссылок на ячейки в диалоговом окне Аргументы функции можно не набирать адреса вручную, а вводить их, выделяя ячейки. При этом адрес ячейки будет занесен в поля окна Аргументы функции, а вокруг самой ячейки появится пунктирная рамка.

Аналоги русских и английских функций

В русской локализованной версии Excel используются локализованные названия функций. Также можно использовать и "родные" английские названия функций. Чтобы получить английское название функции, делаем следующее:

  • Введите русскую формулу в ячейку [A1]
  • В VBE, в окне Immediate скопируйте следующую строчку кода и нажмите ENTER:
    ?[A1].Formula
    или
    ?ActiveCell.Formula
  • На экране появится название функции на английском языке

Теперь перед нами стоит обратная задача. Мы имеем английское название функции и хотим узнать ее локализованное название.

  • В VBE, в окне Immediate скопируйте следующие строчку кода, установите курсор на первой строчке и дважды нажмите на ENTER:
    [A1].Formula="=SUM(B1:B10)"
?[A1].FormulaLocal
  • На экране отобразится локализованное название функции

Как настроить дату, которая меняется каждый день автоматически?

Используйте фукнцию =сегодня() (англ. =Today()).


Суммирование чисел

Одной из самых часто используемых операций с числами является их автоматическое суммирование. В Excel имеется встроенная формула, предназначенная для суммирования чисел, которая записывается как СУММ. Чтобы сложить несколько чисел, необходимо выполнить же действия, что и при использовании любой другой функции

  1. Выделить ячейку, в которой должна находиться сумма.
  2. Набрать в ней =Сумм() и в скобках указать адреса ячеек. Если вы суммируете несколько ячеек, расположенных последовательно, введите в скобках ссылку на первую, поставьте двоеточие и затем введите ссылку на последнюю ячейку. Если ячейки не расположены рядом, их адреса нужно перечислить через запятую.

Для использования в формуле функции суммирования не обязательно вводить ее в ячейке. Можно использовать также окно Мастер функций или список часто используемых функций в поле Имя.

Кнопка Автосумма

Наряду с суммированием чисел посредством использования функции СУММ Excel предлагает более быстрый способ сложения последовательно расположенных строк и столбцов - использование кнопки Автосумма, которая по умолчанию вынесена на панель инструментов Стандартная.

Чтобы выполнить суммирование при помощи этой кнопки, выполните следующее:

  1. Сделайте активной ячейку, в которой будут представлены результаты суммирования. При этом имейте в виду, что если необходимо суммировать числа в столбце, результат суммы должен быть расположен внизу. Если же нужно суммировать числа в строке, сумма должна быть расположена справа.
  2. Нажмите кнопку Автосумма на панели инструментов Стандартная. В выделенной ячейке появится функция СУММ, которая суммирует все числа в текущем столбце или строке. Диапазон ячеек, определенный программой для суммирования, будет обведен пунктирной рамкой. Если подтвердить ввод нажатием клавиши Enter, формула будет введена.

Если диапазон ячеек, выбранный программой для суммирования, неверен, вы можете изменить его, переместив границу, которая окружает ячейки, в нужном направлении. Можно изменить размер диапазона или же переместить его на другие ячейки.

Несмотря на свое название, кнопка Автосумма дает возможность выполнения не одной, а нескольких операций. С ее помощью можно также выбрать другие часто используемые функции. Для доступа к списку с их названиями щелкните на треугольнике рядом с кнопкой Автосумма

При помощи кнопки Автосумма можно также выполнять несколько операций суммирования одновременно. Это позволяет сэкономить время при расчетах. Для выполнения операции одновременного сложения чисел в нескольких столбцах и строках выполните следующее:

  1. Удерживая нажатой левую кнопку мыши, выделите нужную зону ячеек. При этом нужно помнить, что если требуется выполнить суммирование:
    • по столбцам - необходимо выделить только зону с заполненными ячейками
    • по строкам - необходимо выделить на один столбец дальше последней заполненной ячейки. Если этого не сделать, может быть выполнено суммирование по столбцам
    • по строкам и столбцам одновременно - необходимо выделить на один столбец правее последнего заполненного столбца и на одну строку ниже последней заполненной строки
  2. Нажмите кнопку Автосумма на панели инструментов Стандартная. Excel суммирует столбцы и строки одновременно, не показывая предварительно создаваемых функций. При этом если задано суммирование:
    • по столбцам - результаты появятся в ячейках, расположенных под самыми нижними ячейками выделения
    • По строкам, результаты появятся в последних правых ячейках, которые были выделены
    • столбцам и строкам одновременно - результаты появятся в последних правых и нижних ячейках, которые были выделены

При одновременном суммировании нескольких столбцов и ячеек нельзя изменить диапазон ячеек, выбранный программой для суммирования, переместив границу, которая окружает ячейки в нужном направлении


Работа с датами

Одним из самых распространенных форматов, используемых в Excel, являются даты. Напомним, что программа поддерживает большинство вариантов записи дат и в большинстве случаев распознает дату автоматически при вводе. Однако если программа по каким то причинам не «увидела» дату во введенном значении или же если нужно выбрать другой вариант отображения таких данных, это можно сделать в уже знакомом вам окне Формат ячеек

Для быстрого ввода текущей даты в ячейку можно использовать сочетание клавиш Ctrl+Ж

Считать промежутки между датами вручную довольно сложно, ведь нужно учитывать количество дней в каждом месяце. Excel может выполнять такую работу автоматически.Для определения промежутка времени между датами проделайте следующее:

  1. Выделите ячейку, в которую нужно внести число, определяющее количество дней между датами.
  2. Введите формулу, которая должна содержать адреса ячеек и знак вычитания. Например, если ячейка С2 содержит дату 09.05.1961, а ячейка D2 - дату 26.11.1947, формула будет выглядеть так: =C2-D2. Можно вводить в формулу не адреса ячеек, а сами даты. Чтобы программа восприняла их корректно, заключите их в кавычки: ="09.05.1961"-"26.11.1947". Обратите внимание, что если в формуле используются ссылки на ячейки, а не ввод дат вручную, полученный результат будет отображен в формате Дата.
  3. Чтобы увидеть, сколько дней прошло между двумя датами, выделите ячейку с результатом и измените ее формат на Числовой или Общий в окне Формат ячеек.

Можно вычислять не только промежутки между заданными датами, а также определять, какая дата будет на календаре через заданное количество дней. Для этого необходимо составить формулу, в которой сложить значение текущей даты и необходимого количества дней. Например, если сегодня 7 апреля 2004 и нам нужно узнать, какое число будет через 22 дня, то формула будет выглядеть так: ="07.04.2004"+22. Вместо даты также можно указать адрес ячейки, в которой она расположена. Обратите внимание, что если в формуле используются значения дат, введенные вручную, полученный результат будет отображен в формате Общий. Чтобы увидеть искомую дату, выделите ячейку с результатом и измените ее формат на Дата. Таким же образом можно вычислять даты в прошлом. В этом случае используется несуммирование, а вычитание данных.


Буфер обмена

По умолчанию, при выполнении команды Вставить Excel вставляет в ячейку тот объект, который был занесен в буфер последним. Область задач Буфер обмена позволяет выбрать объект для вставки. Чтобы вставить объект из буфера обмена, достаточно выделить ячейку, в которую нужно вставить, и щелкнуть на нужном фрагменте в области задач.

Рассмотрим пример работы буфера обмена с несколькими фрагментами данных. Допустим, нужно составить таблицу, в которой используются данные из других таблиц. Для этого необходимо выполнить следующие действия.

  1. Дважды нажмите сочетание клавиш чтобы вызвать область задач Буфер обмена. Если в буфере обмена находятся какие то данные, нажмите кнопку Очистить все.
  2. Откройте рабочую книгу, из которой нужно скопировать данные для первого товара.
  3. Выделите нужную ячейку и нажмите кнопку Копировать на панели инструмен тов Стандартная. Убедитесь, что фрагмент таблицы появился в буфере обмена.
  4. Скопируйте в буфер обмена все необходимые данные. Обратите внимание на последовательность копирования.
  5. Если вы ошиблись и ввели ненужный фрагмент данных, подведите указатель мыши к его изображении в буфере обмена, щелкните на стрелке и выберите команду Удалить в появившемся меню
  6. После добавления в буфер обмена всех необходимых данных вернитесь в основную книгу
  7. Установите курсор в верхнюю ячейку столбца, в который будут внесены данные. Нажмите кнопку Вставить все в области задач Буфер обмена

Чтобы отключить расширенный режим работы с буфером обмена, выполните одно из следующих действий.

  • Закройте область Буфер обмена, щелкнув на кнопке Закрыть
  • Щелкните правой кнопкой мыши на пиктограмме Буфер обмена, которая находится в области уведомления, и выберите команду Прекратить сбор данных


Построение диаграмм

Диаграммы позволяют наглядно отображать числовые данные. При помощи диаграмм можно проследить, как изменяются данные, увидеть развитие того или иного проекта в динамике. Диаграммы превращают похожие друг на друга столбцы цифр в красочные графические объекты, которые легко воспринимать и приятно изучать. Создание диаграмм в Excel - несложная операция, поэтому использовать их может даже начинающий пользователь. Кроме того, диаграммы связаны с данными таблицы, поэтому при изменении числовых значений в ячейках они также автоматически изменяются. Таким образом, можно составить диаграмму один раз и использовать ее постоянно, как бы ни изменялись значения в ячейках таблицы.

Мастер диаграмм

Для создания диаграмм в Excel предусмотрен Мастер диаграмм. Следуя его инструкциям, можно быстро и легко составить диаграмму любой сложности. Для вызова окна Мастер диаграмм выделите диапазон ячеек, содержащий данные для внесения в диаграмму, после чего выполните одно из следующих действий:

  • выберите в меню команду Вставка | Диаграмма
  • нажмите кнопку Мастер диаграмм на панели инструментов Стандартная
  • вызовите контекстное меню, щелкнув на ярлыке листа правой кнопкой мыши, выберите в нем команду Добавить и в диалоговом окне Вставка выберите значок Диаграмма

Диалоговое окно Мастер диаграмм позволяет построить диаграмму в четыре этапа. На первом этапе необходимо выбрать тип диаграммы из списка. Каждый тип имеет несколько видов. Например, тип График имеет семь видов. Всего в программе более 70 видов диаграмм. Кроме этих типов существуют нестандартные диаграммы, получить доступ к которым можно, перейдя на вкладку Нестандартные. Для задания оптимального вида и типа диаграммы используется кнопка Просмотр результата. При ее нажатии в окне просмотра отобразится выбранный тип диаграммы с вашими данными. Когда вы определитесь с типом диаграммы, можно переходить ко второму шагу, на котором выбирают диапазон данных для построения диаграммы. Если изображение, представленное на рисунке предварительного просмотра, вас устраивает, то переходите к третьему шагу. Если же нужно что то исправить, то измените положение переключателя Ряды в: или нажмите кнопку, расположенную справа от поля Диапазон, для изменения диапазона ячеек, которые войдут в диаграмму.

В третьем окне Мастера диаграмм можно установить различные свойства диаграмм: название диаграммы и осей координат, добавление к диаграмме легенды и ее положение, наличие линий сетки и пр. Легендой называют прямоугольник на диаграмме, который содержит условные обозначения рядов данных в виде цветного значка и их названия.

Названия и количество вкладок на третьем этапе создания диаграммы в диалоговом окне Мастер диаграмм различаются в зависимости от типа и вида выбранной на первом этапе диаграммы.

Последнее диалоговое окно Мастера диаграмм позволяет определить положение на листе. Она может располагаться на том же рабочем листе, где находятся данные, или на отдельном листе.

Форматирование текста диаграммы

При работе с диаграммой может потребоваться изменить форматирование некоторых ее элементов. Сделать это можно в диалоговом окне Формат подписей данных или с помощью инструментов панели Форматирование.

Для внесения изменений в текстовые элементы таблицы выделите их и измените шрифт, размер, цвет и/или начертание, используя соответствующие кнопки на панели инструментов.

Чтобы получить доступ к другим настройкам форматирования и иметь возможность предварительно посмотреть, как будет выглядеть тот или иной элемент с заданными настройками, используется диалоговое окно Формат подписей данных . Для его вызова выполните одно из следующих действий:

  1. дважды щелкните на тексте, формат которого нужно изменить
  2. щелкните на тексте правой кнопкой мыши и выберите в контекстном меню пункт Формат подписей данных

Диалоговое окно Формат подписей данных содержит четыре вкладки:

  • Выравнивание - изменение параметров выравнивания текста по горизонтали и по вертикали, выбор положения подписи и направления текста.
  • Вид - при построении диаграммы Excel автоматически выделяет ее разными цветами. Однако цветовая схема, предложенная программой, может вас не устраивать. В этом случае вы можете изменить цвета на диаграмме. Для этого выберите цвет элемента в области Заливка Если необходимо, то нажмите на кнопку Способы заливки и выберите один из предлагаемых способов заливки: градиент, текстура, узор и рисунок.
  • Шрифт - изменение параметров шрифта. Можно задать шрифт, его начертание, подчеркивание, а также цвет и фон.
  • Число - выбор формата представления данных. Данная вкладка идентична одноименной вкладке диалогового окна Формат ячеек.

Ввод в диаграмму дополнительного текста

По умолчанию диаграмма содержит только числовые и графические данные, однако в некоторых случаях необходимо также вводить в диаграмму текст. Текстовыми данными являются название диаграммы, ее осей координат и пр. Некоторые текстовые блоки можно внести в диаграмму на этапе ее построения, используя Мастер диаграмм (в частности, название диаграммы, значения ячеек, названия категорий). Однако этого не всегда достаточно. Иногда необходимо внести в диаграмму специфические текстовые данные, разместив их в определенных местах. Для этого используется панель инструментов Рисование. Для отображения этой панели используйте один из следующих способов:

  • нажмите кнопку Рисование на панели инструментов Стандартная
  • щелкните правой кнопкой мыши на любой из отображенных панелей инструментов и выберите из списка пункт Рисование; выполните команду Вид | Панели инструментов | Рисование

Вставка в диаграмму графического объекта

Кроме дополнительных текстовых элементов в диаграммах используются графические элементы (например, стрелки, линии и другие фигуры). Для добавления в диаграмму графического объекта также используются кнопки панели инструментов Рисование.

Для добавления в диаграмму стандартного графического объекта выполните описанные ниже действия

  1. Нажмите кнопку Автофигуры и выберите из списка фигуру для вставки
  2. Поместите курсор в место вставки объекта и, не отпуская кнопку мыши, нарисуйте выбранный объект
  3. Когда объект будет готов, отпустите кнопку мыши
  4. Для редактирования графического объекта выделите его, щелкните на одном из маркеров изменения размера и переместите его мышью

Пунктирная линия укажет, как будет выглядеть объект после редактирования. В диаграмму можно вставлять не только стандартные автофигуры, которые доступны в одноименном списке панели инструментов Рисование, но и другие объекты из коллекции Microsoft. Это поможет разнообразить диаграммы и сделать их запоминающимися.

Использование диаграмм для анализа данных

Диаграммы - очень удобное средство не только для графического отображения цифровых данных, но и для их анализа. При подборе наилучших значений параметров можно найти исходное значение, которое приведет к наилучшему результату, если использовать его в формуле. Чтобы изменить значения, отображаемые на диаграмме, необходимо перетащить маркеры данных или же подобрать параметры, полученные из формул. При изменении значений в диаграмме изменяются исходные значения в ячейках. Для разных диаграмм изменение значений происходит по разному. Обычно для этого нужно выделить область значений, которую необходимо изменить, и перетащить маркер на нужную позицию. Если значение изменяемого параметра получено из формулы, то при его изменении появится диалоговое окно Подбор параметра


Использование списков в качестве баз данных

Многие таблицы в Excel имеют вид списков данных. Excel дает возможность использовать списки в качестве простых баз данных и работать с ними, применяя многочисленные средства для работы с данными. При помощи встроенных средств Excel можно быстро упорядочивать и сортировать данные, изменять их, искать в базе и отбирать нужные данные. Для составления баз данных в Microsoft Excel используются свои правила, а для элементов списков - определенная терминология. Списки должны содержать заголовки, и информация в столбцах должна соответствовать этим заголовкам. Категории данных, расположенные в столбцах, называют полями. Списки также содержат записи - информацию о каждом элементе списка. Обычно записями являются строки таблицы.

Чтобы Excel корректно работал со списками, в них не должно быть пустых строк и столбцов, то есть они должны представлять собой единое целое. Их также нужно отделить от других данных пустыми строкам и столбцами, а еще лучше - расположить на отдельном листе. Если ваши списки отделены друг от друга и от других данных, то у вас не будет проблем с выделением списка. Для этого достаточно выделить одну из его ячеек и воспользоваться комбинацией клавиш Shift+Ctrl+8

Для упрощения создания и редактирования списков используется команда Данные | Форма. В диалоговом окне управления списками можно выполнять простейшие действия со списком: удалять ненужные записи, добавлять новые, редактировать текущие записи и пр.

Отбор данных

Если вы имеете дело с большой таблицей, то вполне возможно, что все внесенные в нее данные не нужны вам в повседневной работе. Однако удалять тоже не стоит, так как они могут понадобиться в любую минуту. При помощи средств Excel вы можете сделать так, чтобы на экране отображались только необходимые в данный момент данные. Это поможет вам сконцентрироваться на главном. Для выполнения отбора данных выберите в меню Данные | Фильтр | Автофильтр. После выполнения этой команды таблица изменит вид - в ячейках с названиями полей появятся стрелки, при нажатии которых можно получить доступ к раскрывающему списку. Выбрав из списка критерий, вы увидите только те записи, которые ему соответствуют.

В списке обозначены как постоянные критерии, так и зависящие от конкретного списка. Следующие критерии являются постоянными:

  • Все - если до выбора данного критерия отображались не все данные, то после выбора на экран будет выведен весь список
  • Первые 10 - при выборе этого значения появится диалоговое окно Наложение условия по списку. В нем можно выбрать произвольное количество элементов для просмотра (от 1 до 500) и указать, какую часть списка, нижнюю или верхнюю, вы хотите увидеть. Обратите внимание, этой командой можно обрабатывать только числовые данные. Если же попытаться использовать ее по отношению к текстовым данным, то ничего не произойдет
  • Условие - при его выборе появится диалоговое окно Пользовательский автофильтр, в котором указывают условия фильтрации. Этих условий может быть два. При помощи переключателей И и ИЛИ определяют, должны соблюдаться оба условия или только одно.

Данные, отсеянные в результате фильтрации, не удаляются, а скрываются. Для отключения фильтрации снова выполните команду Фильтр | Автофильтр.

Упражнение. Отбор данных в списке

Откройте рабочую книгу Зарплата. Дополните список записями, чтобы сделать его длиннее. Предположим, что для выполнения задания нам нужно привлечь инженеров, работающих на предприятии. Чтобы просмотреть список всех работающих этой должности и определить, кто именно будет выполнять задание, можно произвести отбор данных.

  1. Выделите одну из ячеек, которые находятся в списке.
  2. Выполните команду Данные | Фильтр | Автофильтр. При этом таблица изменит вид.
  3. Раскройте список поля Должность и выберите критерий инженер. При этом таблица изменит вид - теперь в ней отображены всего две записи.
  4. Однако на предприятии работают не только инженеры, но и главные инженеры, которых тоже можно привлечь к выполнению задания. Чтобы отобрать и те и другие записи, нужно использовать критерий Условие. Выберите его из списка.
  5. В открывшемся окне Пользовательский автофильтр укажите условия фильтрации. В поле Должность выберите критерий содержит. В поле, расположенном справа, наберите инженер или выберите данный пункт из списка
  6. Нажмите кнопку ОК, чтобы подтвердить выбранный критерий отбора. Убедитесь, что теперь в списке присутствуют фамилии инженеров и главных инженеров, работающих на предприятии

Поиск данных

Если вам необходимо найти данные в списке, то можете это сделать при помощи кнопки Критерии диалогового окна формы. Для доступа к нему выполните команду Данные | Форма. Кнопка Критерии позволяет искать в списке по заданным параметрам. Такими параметрами могут быть текстовые и числовые фрагменты, а также выражение. При ее нажатии отобразятся поля списка, которые нужно заполнить. Вы можете выполнять простой поиск по одному из полей, а также расширенный по нескольким полям. Для поиска значений можно использовать как слова и числа, так и специальные подстановочные символы. При задании условий поиска можно использовать такие дополнительные символы:

  • * - заменяет неограниченное количество символов. Вместо этого символа могут быть подставлены любые другие. Например, при вводе критерия *ов будут отобраны все фамилии, которые заканчиваются на ов;
  • ? - заменяет одну букву или другой символ. Вместо этого символа может быть подставлен любой другой. Например, при вводе критерия ????ов будут отобраны все фамилии, заканчивающиеся на ов и содержащие четыре символа перед сочетанием ов.

Чтобы просмотреть записи, соответствующие заданному критерию, используйте кнопки Назад и Далее.

Упражнение. Поиск данных

Для выполнения поиска данных откройте рабочую книгу Зарплата. Предположим, нам нужно найти сотрудников, которые получают зарплату 400 единиц.

  1. Выделите одну ячейку в списке.
  2. Выполните команду Данные | Форма.
  3. Нажмите кнопку Критерии.
  4. В поле Зарплата введите значение 400 и нажмите кнопку Далее.
  5. Убедитесь в правильности полученных результатов. Нажмите еще раз кнопку Далее, чтобы перейти к следующей записи, которая удовлетворяет заданному критерию.
  6. Предположим, что из полученных результатов нам нужно отобрать только тех сотрудников, которые получают зарплату 400 единиц и при этом работают бухгалтерами. Нажмите кнопку Критерии еще раз и в поле Должность введите значение бухгалтер
  7. Нажмите кнопку Далее, чтобы перейти к результатам. Убедитесь, что теперь отобраны только те записи, которые удовлетворяют двум заданным критериям поиска.

Сортировка данных

Сортировку данных, в отличие от отбора, выполняют не только для того, чтобы записи было легче просматривать. Целью сортировки часто является упорядочивание записей на основе выбранного критерия. Сортировку используют, если данные набирались в таблицу постепенно и каждая запись добавлялась просто на одну строку ниже. Когда такой список подготовлен, оказывается, что найти в нем информацию очень трудно. При использовании сортировки данные можно упорядочить по выбранному критерию. Для сортировки списка существует диалоговое окно Сортировка диапазона, которое открывается выполнением команды Данные | Сортировка.

В этом окне можно сортировать данные по трем полям. Сначала следует выбрать название поля из списка Сортировать по, а затем в случае необходимости задать дополнительные поля для сортировки. Наконец, необходимо установить требуемое положение переключателя: по возрастанию или по убыванию. При выборе первого положения сортировка будет по возрастанию сверху вниз при сортировке строк и слева направо при упорядочивании столбцов. Если переключатель установлен в положение по убыванию, то сортировка выполняется в обратном направлении.

Excel упорядочивает данные в следующем порядке:

  • числа - начиная наименьшим отрицательным и заканчивая наибольшим положительным;
  • текст - начиная первой буквой алфавита и заканчивая последней;
  • логические значения типа ЛОЖЬ;
  • логические значения типа значения ошибок - они приводятся в том же порядке, что и до сортировки;
  • пустые значения - после сортировки они всегда занимают место в конце списка, независимо от положения переключателей по возрастанию и по убыванию.

Кроме основных правил сортировки, установленных по умолчанию, в Excel предусмотрена возможность выбора дополнительных параметров упорядочивания данных. Для доступа к ним необходимо нажать кнопку Параметры в окне Сортировка диапазона. Откроется диалоговое окно Параметры сортировки. В этом окне доступны следующие возможности:

  • в списке Сортировка по первому ключу можно установить дополнительные критерии упорядочивания данных, которые должны быть отсортированы особым образом. Это могут быть, к примеру, дни недели или месяцы. Для таких данных сортировка в алфавитном и числовом порядках не подходит;
  • флажок Учитывать регистр позволяет определить, нужно ли учитывать строчные и прописные буквы при сортировке;
  • установка переключателя, определяющего порядок сортировки данных: по строкам или по столбцам.

Для сортировки данных вы также можете использовать кнопки Сортировка по возрастанию и Сортировка по убыванию на панели инструментов Стандартная. Они не предоставляют дополнительных настроек (например, учет регистра), но позволяют быстро упорядочить данные.

Построение сводных таблиц

Когда таблица с данными не очень объемная, управлять ею несложно. Расчеты не займут много времени, и вы легко, используя нужные формулы и функции, сможете вычислить, например, общую сумму затрат или доходов. Однако задача усложняется, если таблица достаточно большая. Чтобы просмотреть ее, нужно очень много времени, не говоря уже о том, чтобы выполнить по ней какие нибудь расчеты. Особенно трудно управлять большими таблицами, если они расположены на нескольких листах. В таких случаях на помощь пользователю могут прийти сводные таблицы. Они обобщают данные и упрощают их просмотр. Особенность сводных таблиц в том, что они позволяют лишь просматривать данные, а не изменять их. На основе сводных таблиц можно создать диаграмму, чтобы представить данные еще нагляднее.

Упражнение. Построение сводной таблицы

Для выполнения данного упражнения вам нужно создать новую рабочую книгу и внести в нее некоторые данные. Допустим, у нас есть в разных городах три магазина, в которых продаются компьютерные комплектующие. Нам нужно знать, сколько товаров каждого типа продается в магазинах за указанный период времени, чтобы соответствующим образом корректировать поставки.

  1. Создайте таблицу и укажите в ней названия товаров, а также продаж за три месяца. На втором и третьем листах таблицы введите данные для магазинов в других городах. Обратите внимание, что три таблицы должны быть оформлены одинаково.
  2. Выделите одну из ячеек списка и выполните команду Данные | Сводная таблица
  3. В первом окне Мастера сводных таблиц укажите, где находятся ваши данные. В нашем случае нужно установить переключатель в положение в нескольких диапазонах консолидации. В качестве типа создаваемого отчета выберите сводная таблица.
  4. Нажмите кнопку Далее, чтобы продолжить построение сводной таблицы. В следующем окне Мастера сводных таблиц укажите, хотите вы самостоятельно создать поле страницы или программа может сделать это за вас. Когда списки, находящиеся на разных листах аналогичные, можно поручить это Excel и установить переключатель в положение Создать одно поле страницы.
  5. Нажмите кнопку Далее. В следующем окне Мастера сводных таблиц необходимо указать диапазон, в котором находятся ваши списки. Для этого нажмите кнопку, расположенную справа от поля Диапазон, и выделите диапазон в рабочей таблице. Когда операция будет завершена, снова нажмите кнопку добавления диапазона, а в диалоговом окне Мастер сводных таблиц - кнопку Добавить для добавления диапазона к списку, на основе которого будет построена таблица.
  6. Повторите операцию для всех диапазонов ячеек. Вы можете переключаться на другие рабочие листы для выделения диапазонов.
  7. Нажмите кнопку Далее и в последнем окне Мастера сводных таблиц укажите, где должна быть создана сводная таблица: на новом листе или на существующем.
  8. Нажмите кнопку Готово, чтобы завершить создание сводной таблицы. По получившейся таблице очень удобно наблюдать за динамикой продаж и за общими объемами.
  9. Для удобства использования таблицы предусмотрен вывод на экран только некоторых записей. Чтобы задать просматриваемые записи, раскройте список Строка и выберите нужные элементы

ВНИМАНИЕ. Сводные таблицы предназначены исключительно для просмотра и анализа данных, а не для их редактирования. Если вам нужно изменить какие нибудь данные, то сделайте это в исходной таблице, после чего нажмите кнопку Обновить данные на панели инструментов Сводные таблицы или выберите одноименную команду в контекстном меню.


Печать документов

Вступление

В большинстве случаев печать таблицы является заключительным этапом работы с ней. К сожалению, многие пользователи забывают или не знают, что рабочая книга на экране монитора не всегда выглядит так, как в распечатанном виде на бумаге. На экране можно не обращать внимания на размер шрифта, регулируя размер букв с помощью масштаба, не использовать границы, не задумываться том, какую ориентацию (книжную или альбомную) лучше использовать для подачи таблицы. Однако если рабочую книгу нужно распечатать, то все эти нюансы становятся очень важными. Если, например, в ячейках таблицы содержится большое количество данных, то некоторые столбцы станут шире. Таких проблем может быть очень много, если не позаботиться о подобных мелочах до того, как документ будут вы веден на печать.

Просмотр перед печатью

Большинство пользователей работают с Microsoft Excel в режиме просмотра Обычный. Данный режим наиболее удобен для повседневной работы, однако если документ нужно вывести на печать, то просмотром таблицы в режиме Обычный ограничиваться нельзя. Дело в том, что многие пользователи устанавливают наиболее удобные для них параметры просмотра таблицы (например, крупный размер шрифта, большой масштаб и т. д.). Когда ваша таблица отображается на экране монитора, это удобно, но на бумаге она может выглядеть совсем по другому. Может оказаться, что вы работаете с большим масштабом, а на самом деле таблица настолько мала, что данные в ней невозможно прочитать. Или наоборот - данные в ячейках набраны таким крупным шрифтом, что на одной странице помещается очень мало информации. Чтобы проверить, как таблица будет выглядеть на бумаге, в Excel существуют два дополнительных варианта просмотра рабочей книги: режим Разметка страницы и Предварительный просмотр.

Разметка страницы

Чтобы представить таблицу в режиме разметки страницы, выполните команду Вид | Разметка страницы.

В этом режиме вы увидите границы страниц и сможете изменить разбивку таблицы на страницы. Для наглядности на каждой странице таблицы крупными серыми буквами указаны номера страниц.

Разбивку таблицы на страницы можно изменять мышью, перетаскивая синие разделители в удобное место. Другой способ установки разделителей - использование меню Вставка. Для установки горизонтального разделителя выполните описанные ниже действия.

  1. Выделите строку, над которой нужно установить разделитель.
  2. Выполните команду Вставка | Разрыв страницы.

Чтобы установить вертикальный разделитель, выполните действия, описанные ниже.

  1. Выделите столбец, расположенный слева от того, рядом с которым нужно установить разделитель.
  2. Выполните команду Вставка | Разрыв страницы.

Для отмены разметки страницы, сделанной вручную, выполните команду Вставка | Убрать разрыв страницы.

Предварительный просмотр

Для просмотра документа перед печатью в Microsoft Excel встроена функция предварительного просмотра. Данный режим показывает, как будет выглядеть таблица после печати на бумаге. Он особенно необходим, если таблица содержит графические объекты, другие внедренные объекты и пр. Для перехода в него выполните одно из следующих действий: нажмите кнопку Предварительный просмотр на панели инструментов Стандартная. Выберите в меню Файл | Предварительный просмотр.

Перейти в режим предварительного просмотра можно только в случае, если активная рабочая книга содержит какие нибудь данные. При попытке перейти в этот режим из пустой рабочей книги программа выдаст предупреждающее сообщение об отсутствии данных для вывода на печать, и окно останется в исходном режиме. В режиме предварительного просмотра вместо стандартных панелей инструментов появляется панель с командами предварительного просмотра. С ее помощью можно отображать следующую или предыдущую страницу. А также переключаться между полностраничным режимом просмотра и режимом увеличения (перейти из полностраничного режима в режим увеличения и обратно можно, щелкнув на любом месте рабочего листа), установить параметры печати и затем напечатать выделенный рабочий лист. Для выхода из режима предварительного просмотра нажмите кнопку Закрыть на панели данного режима.

В режиме Предварительный просмотр, в отличие от режима Разметка страницы, таблица отображается так, как она будет выглядеть на листе бумаги. В частности, в этом режиме вы не увидите ячеек, рабочих листов и других элементов, к которым вы привыкли, работая в режиме Обычный. В режиме предварительного просмотра вместо привычных панелей инструментов появятся несколько кнопок.

Кнопки служат для управления таблицей в этом режиме:

  • Далее - переход к следующей странице таблицы;
  • Назад - переход к предыдущей странице таблицы;
  • Масштаб - увеличение активного листа;
  • Печать - вызов окна с настройками печати;
  • Страница - вызов окна с настройками страницы;
  • Поля - установка полей страницы при помощи мыши и маркеров;
  • Разметка страниц/Обычный режим - переход в режим Разметка страницы или Обычный (Название этой кнопки изменяется в зависимости оттого, какой режимбыл активным до перехода в окно предварительного просмотра.);
  • Закрыть - переход из режима предварительного просмотра в режим Обычный или Разметка страницы (в зависимости от того, в каком режиме вы работали до открытия окна предварительного просмотра);
  • Справка - вызов окна справки по данной теме.

Подготовка документа к печати: поля, колонтитулы, размер и ориентация страниц

Чтобы подготовить документ к печати, необходимо выполнить команду Файл | Параметры страницы. В открывшемся диалоговом окне Параметры страницы обратим внимание на некоторые настройки.

Поля документа

Поля документа - это расстояние между краем страницы и таблицей. Соответственно, чем больше поле, тем меньше столбцов и строк помещается на странице, и наоборот. Любой документ имеет правое, левое, верхнее и нижнее поля. Широкие поля придают документу более респектабельный вид, а узкие позволят поместить большее количество информации. По умолчанию Excelустанавливает такие размеры полей: правое и левое - 2 см, верхнее и нижнее - 2,5 см. Размер полей можно изменять вручную, перейдя в режим предварительного просмотра и нажав кнопку Поля, а также в диалоговом окне Параметры страницы. Чтобы отрегулировать поля в окне Параметры страницы, перейдите на вкладку Поля и установите требуемые размеры полей. Вы можете посмотреть, как будет выглядеть документ с установленными вами па раметрами, на образце. Можно также нажать кнопку Просмотр, после чего программа автоматически перейдет в режим предварительного просмотра.

На вкладке Поля можно также определить ориентацию таблицы на странице относительно полей. Так, чтобы выровнять ее относительно правого и левого полей, установите флажок горизонтально, а чтобы центрировать таблицу относительно верхнего и нижнего полей - флажок вертикально. Эти две настройки вы можете использовать их вместе.

Колонтитулы

Одним из атрибутов профессионально оформленных таблиц является наличие верхних и/или нижних колонтитулов. Они представляют собой текст, который печатается в верхней и/или нижней части каждой страницы. При этом такой текст может быть одинаковым для группы страниц. Таким образом, на каждом листе может быть отображено имя автора, название документа, текущая дата и т. д. Когда вы готовите документ к печати и хотите, чтобы на нем присутствовали колонтитулы, необходимо установить для них некоторые параметры. Размеры колонтитулов устанавливаются на уже знакомой вам вкладке Поля диалогового окна Параметры страницы. По умолчанию каждый из них равен 1,3 см - это расстояние от верхнего или нижнего края листа до колонтитула. Чтобы ввести текст, который будет отображаться в колонтитулах, перейдите на вкладку Колонтитулы. Выберите из списков Верхний колонтитул и Нижний колонтитул подходящий шаблон колонтитулов. Как выглядит выбранный колонтитул, вы увидите в окне предварительного просмотра. Если ни один из предлагаемых Excel шаблонов вас не устраивает, то можете создать колонтитул самостоятельно. Для этого используйте кнопки Создать верхний колонтитул и Создать нижний колонтитул. В диалоговом окне создания колонтитула находятся кнопки для вставки в колонтитул различных элементов. Можно добавить номер страницы и общее количество страниц в таблице, текущее время и дату, имя файла активной книги и название текущего листа. В зависимости от того, где вы хотите поместить колонтитул, введите данные в одно из трех полей окна. Например, если текст колонтитула нужно центрировать, то запишите его в поле В центре.

Названия строк и столбцов

Названия строк и столбцов в многостраничном документе иногда необходимы. Если у вас есть таблица, которая продолжается на втором листе, то как понять, какие данные скрываются за колонками цифр? На первой странице это можно увидеть, прочитав название столбца, но на следующих смысловое значение будет утрачено. Однако вы можете распечатать эту нужную информацию на всех страницах документа. Необходимые для этого настройки расположены на вкладке диалогового окна Параметры страницы Чтобы указать строку, которую нужно повторять вверху каждой страницы, введите адрес ячейки, содержащей нужные данные, в поле Сквозные строки или нажмите кнопку выбора ячейки в правой части поля и выделите ячейку в рабочей таблице. Для указания столбца, который нужно повторять в левой части каждой страницы, введите адрес ячейки, содержащей нужные данные, в поле Сквозные столбцы или нажмите кнопку в правой части поля и выделите ячейку в таблице. Таким образом можно выделять и диапазон ячеек.

Диаграммы

Если на рабочем листе, который необходимо вывести на печать, есть диаграммы, то нелишним будет предварительно проверить их параметры. Настройки печати диаграмм устанавливаются на вкладке Диаграмма диалогового окна Параметры страницы.

ВНИМАНИЕ! Если диаграмма на листе отсутствует, то закладки Диаграмма в диалоговом окне Параметры страницы нет

Пользователь имеет возможность установить размер диаграммы при выводе на печать: использовать всю страницу, уместить таблицу на листе или сохранить пользовательский размер. Здесь же задают параметры черновой или черно белой печати диаграммы, если необходимо.

Когда документ будет полностью подготовлен к печати, необходимо обратиться к настройкам принтера. Их можно установить в диалоговом окне Печать. ВНИМАНИЕ! Если необходимо задать настройки принтера, то не используйте для этого кнопку Печать на панели инструментов Стандартная. При ее нажатии диалоговое окно Печать не появится, а документ сразу начнет распечатываться.

Печать части таблицы

Если таблица достаточно большая, то во многих случаях не имеет смысла выводить ее на печать полностью, а достаточно распечатать небольшую часть. Возможности Microsoft Excel позволяют это сделать двумя способами: в настройках печати или на этапе подготовки таблицы к печати.

Упражнение. Вывод на печать части таблицы

Нужно вывести на печать не всю таблицу, а ту некоторую ее часть

  1. Выделите требуемый диапазон ячеек
  2. Нажмите сочетание клавиш Ctrl+P
  3. В области Вывести на печать диалогового окна Печать установите переключатель в положение выделенный диапазон.
  4. Нажмите кнопку ОК, чтобы распечатать выделенный фрагмент таблицы. Убедитесь, что распечатан нужный диапазон ячеек.

Теперь нужно распечатать только столбец

  1. Снимите выделение со столбца Фамилия и выполните команду Файл | Параметры страницы.
  2. Перейдите на вкладку Лист.
  3. Задайте диапазон ячеек, которые вы хотите вывести на печать. Для этого введите адреса ячеек диапазона в поле Выводить на печать диапазон или нажмите кнопку в правой части поля и выделите диапазон в рабочей таблице. Чтобы задать несмежные диапазоны, при выделении ячеек удерживайте клавишу Ctrl. Несмежные диапазоны будут напечатаны на отдельных страницах.
  4. Нажмите кнопку Печать для перехода к диалоговому окну Печать.
  5. Нажмите кнопку ОК, чтобы распечатать документ. Убедитесь, что на печать выводится только выбранный диапазон.

Многократная печать одного диапазона

Если таблица, с которой вы работаете, остается неизменной, а изменяются только данные в ней, то каждый раз при необходимости распечатки указывать диапазон печати может быть утомительно. В этом случае лучше воспользоваться специальной настройкой Область печати, которая позволяет задать нужный диапазон один раз и в дальнейшем при печати не указывать его снова.

Упражнение. Выбор диапазона для многократной печати

Предположим, нам постоянно требуется распечатывать область таблицы без заголовка. Для задания диапазона многократной печати выполните описанные ниже действия.

  1. Выделите диапазон ячеек, которые будут выведены на печать.
  2. Выполните команду Файл | Область печати | Задать.
  3. Убедитесь, что заданный диапазон выделен пунктирной линией.
  4. Нажмите кнопку Печать на панели инструментов Стандартная, чтобы распечатать таблицу. Убедитесь, что распечатан только заданный диапазон.

Если в дальнейшем вам нужно будет напечатать другой диапазон выполните команду Файл | Область печати | Убрать.


Ресурсы

Приведем ссылки на самые интересные ресурсы, посвященные Microsoft Excel:

  • http://office87.hut.ru - большое количество полезной информации о Microsoft Excel (советы по работе, статьи, хитрости и решения проблем;
  • http://rusdoc.df.ru/material/lang/vb/excel_vba.html - данная страница интересна пользователям, которые занимаются программированием. На ней рассмотрены программирования Excel VBA в форме вопросов и ответов;
  • http://www.homepc.ru/faq/14839/print.html - сборник часто возникающих у начинающих пользователей Excel вопросов и толковые ответы на них.


EXCEL: Пасхальное яйцо

В Excel2K гонки:
1. Запустите Excel 2000
2. Выберите "Save as web page" (сохранить как Web-страница) из меню File.
3. Выберите "Save: Selection: Sheet" (Сохранить выделенный лист)
4. Отметьте галочку "Add interactivity" (Добавить интерактивнось) и нажмите Save.
5. Выйдите из Excel.
6. Откройте получившийся файл в MS Internet Explorer 4/5.
7. Прокрутите вниз до строки 2000, колонки WC.
8. Выделите строку 2000 целиком и нажимайте Tab, пока колонка WC снова не выделится.
9. Удерживая нажатыми Shift - Ctrl - Alt щелкните мышкой по логотипу Microsoft в левом верхнем углу.
10. Используйте стрелки для управления машинкой, пробел для стрельбы, H - для включения фар, а О - для масла.
11. Выход из игры по Esc.


WORD: Common

WORD: Общие советы

Переводчик

А вы знаете, что Word можно использовать для перевода незнакомых вам слов? Выберите слово, нажмите правую кнопку мыши. В контекстном меню выберите пункт Перевод - справа откроется панель с переведённым словом.

Как вставить в документ страницу альбомной ориентации, сохранив при этом сквозную нумерацию страниц

Эту задачу можно решить, воспользовавшись вставкой разрывов разделов в документ редактора Word. Перед страницей альбомной ориентации нужно вставить разрыв раздела. Сделать это можно, выбрав Вставка | Разрыв | Новый раздел со следующей страницы.

В новом разделе с помощью команды Файл | Параметры страницы нужно установить нужный вариант ориентации страницы, указав при этом его применение - "К текущему разделу". После этой страницы нужно вновь вставить разрыв раздела и в новом разделе точно так же задать уже книжную ориентацию страницы, применив ее к текущему разделу.

Отображение пути файла в Word

По умолчанию в заголовке программы Word отображается только имя редактируемого файла. При работе с одноимёнными документами, размещёнными в разных директориях (или на разных носителях), может потребоваться уточнение месторасположения файлов. Антон Кокин предлагает путём внедрения в шаблон Normal.dot (Normal.dotx) небольшого макроса научить Word отображать в заголовке полный путь к каждому открытому в редакторе файлу.

[Word]
Sub AutoOpen()
ActiveWindow.Caption = ActiveDocument.FullName
End Sub

[Excel]
Private Sub Workbook_Open()
    ActiveWindow.Caption = FullName
End Sub

Приведённый код нужно, скопировав в буфер обмена Windows, перенести в окно вызываемого посредством меню "Макрос -> Создать" редактора Visual Basic и сохранить изменения в шаблоне Normal.dot.

Избавиться от форматированного текста

Иногда, вставляя текст из буфера обмена, мы получаем ненужное стилевое оформление (например, при копировании текста с веб-страниц). Чтобы быстро избавиться от ненужных стилей, достаточно выделить нужный текст и нажать комбинацию клавиш Ctrl+пробел или Ctrl+Shift+Z.

Вставить линию в документ

Вы хотите отделить параграф линией? Нажмите трижды клавишу знака переноса и клавишу Enter и вы получите тонкую линию. Нажмите трижды клавишу знака нижнего подчеркивания и клавишу Enter — получите жирную линию. А при нажатии трижды клавиши знаков равенства и клавиши Enter вы получите двойную линию.

Строка без буллита

При создании маркированного списка в Word нередко возникает ситуация, когда необходимо оставить следующий пункт без буллита. Для этого необходимо нажать комбинацию клавиш Shift+Enter. В следующей строке, когда вы нажмете Enter, новая строчка вновь будет с буллитом.

Например:

• Гвозди

• Шурупы

Винты

• Пироги

• Сапоги

Web-странички с минимумом избыточных тэгов

Когда вы сохраняете Web-странички или посылаете электронные сообщения в HTML-формате с помощью Microsoft Word, в документ добавляются дополнительные тэги, что позволит вам использовать всю функциональность Word для дальнейшей работы с документом.

Для того чтобы уменьшить размер Web-странички и e-mail-сообщения в HTML-формате, сохранять данные можно в специальном фильтрованном формате (filtered HTML) — в этом случае лишние тэги будут удалены.

Если вы откроете Web-страницу, сохраненную в режиме filtered HTML, в программе Word, часть функциональности по дальнейшему редактированию этого документа, возможно, будет утрачена. Например, маркированные списки и нумерованные списки будут отображаться, однако возможность их видоизменения средствами Word будет утрачена.

Поэтому следует использовать режим filtered HTML только на финальной стадии — перед непосредственным переводом в HTML.

Если вы планируете работать далее над форматированием документа, полезно создавать два файла: один в обычном формате Word, а другой в режиме filtered HTML.

Сравнение документов

Начиная с Word 2003, появилась возможность сравнения документов в режиме side by side, позволяющая вызвать сразу два документа и скроллировать их одновременно и отдельно, сравнивая те или иные разделы двух документов.

Откройте два документа и выберите команду Window | Compare Side By Side With... Если у вас открыто только два документа, именно они и будут сравниваться — в противном случае программа попросит уточнить, какие именно документы необходимо сравнить.

Для управления документами появляется плавающая панель. Нажатие левой кнопки меняет режим скроллирования (включается/выключается режим одновременного скроллирования), а правая кнопка позволяет вернуть позицию окна в положение, с которого вы начали сравнение документов.

Изменение расстояние между строками

Самые распространенные межстрочные интервалы (расстояния между строками) – одинарный, полуторный и двойной. Для установления интервала используются комбинации клавиш или диалоговое окно Абзац:

  • Чтобы получить расстояние между строками в один интервал, следует нажать Ctrl + 1.
    Команда используется в одном абзаце или в нескольких, выделенных в блок.
  • Чтобы получить расстояние между строками в полтора интервала, следует нажать Ctrl + 5.
  • Чтобы получить расстояние между строками двойной интервал, следует нажать Ctrl + 2.

Примечание: при нажатии комбинации Ctrl + 5 нужно пользоваться клавишей 5 на основной клавиатуре, а не на дополнительной цифровой клавиатуре.

Иногда необходимо использовать сноски в тексте в Word. Для этого нужно поставить курсор после слова, для которого необходима сноска, и нажать Ctrl+Alt+F (раскладка клавиатуры не имеет значения). Внизу листа появится черта, под ней номер сноски (этот же номер появится после слова в верхнем регистре) и мигающий курсор.

Если нажимать клавиши Shift+2, то Word выводит на экран кавычку « вместо ". Если вас не устраивает подобное поведение, то в Автозамене нужно снять галочку с пункта Заменять прямые кавычки на парные

Чтобы подсчитать число символов в документе, выберите в меню Сервис | Статистика. Для Word 2007 выберите Рецензирование | Статистика.

Как правило, буквица — это первая буква абзаца, однако буквицу можно сделать и на основе первого слова предложения. Технически все осуществляется точно так же: выделяете первое слово в предложении, в меню Формат выбираете команду Буквица и в открывшемся окне определяете тип буквицы.

Если вы не хотите, чтобы инициалы вашего босса в отчете улетели на другую строку, оторвавшись от фамилии, а слово руб было на другой странице после цифры - количества этих самых рублей, то используйте неразрывные пробелы - в Word'е они вставляются по сочетанию клавиш [Ctrl] + [Shift] + [Пробел]. То есть сочетание, например, слов Билл (Ctrl + Shift + Пробел) Гейтс всегда будет на одной строке, в отличие от Билл(пробел)Гейтс

Наиболее часто встречающиеся опечатки исправит функция Автозамена (Сервис - Автозамена). Если существует слово, которое часто вводится неправильно, можно ввести в окне Автозамены правильную и неправильную версии его написания. После того, как это будет сделано, Word будет исправлять ошибку автоматически, не спрашивая разрешения пользователя. Кстати говоря, Автозамену можно использовать не только для устранения опечаток, но и для быстрого ввода каких-нибудь слов и предложений. Так, например, если вам часто приходится набирать фразу "Microsoft Office", введите ее в окне Автозамены как правильный вариант, а как неправильный - Mic. Теперь после набора этих трех букв появится целая фраза.

Microsoft Word запоминает около тридцати действий пользователя. Их можно отменить последовательно или же все сразу. Нажмите на стрелку, расположенную справа от кнопки Отменить, и выберите количество отменяемых действий. Ну, а для тех, кто умудряется ошибаться даже при исправлении ошибок, предусмотрена функция Вернуть (Redo), позволяющая отменить отмененные действия (извините за каламбур). Кнопка Вернуть также находится на панели инструментов, а с клавиатуры эта функция вызывается через CTRL+Y

Если в Word'е нажать Ctrl и крутить скроллинговое колесико мыши, то будет увеличиваться или уменьшаться масштаб с которым отображается лист на экране.

Если вы работаете с большим количеством документов, загруженных в Word, постоянно изменяя многие из них, но вполне может возникнуть ситуация, что вам, скажем, надо срочно отойти от компьютера. Естественно, есть опасения, что в случае, когда наступит сбой в электропитании или иная неприятная ситуация, может произойти потеря несохраненных данных. Но как сохранить все документы? По одному - но их много, и время уйдет немало. Закрыть Word и посохранять все по очереди? Тоже не быстро. Лучше нажмите Shift и кликните мышью на меню Файл - вы увидите там новый пункт меню: Сохранить все (или Закрыть все), который и следует выбрать в такой ситуации

Иногда, при наборе текста, забывают отключить клавишу CAPS LOCK, и тогда весь текст идет большими буквами. Или наоборот. Можно не поднимая головы напечатать приличный кусок текста не теми буквами. Что делать?
Выделите строку или абзац или весь текст. Удерживая клавишу Shift, кликайте на F3, тогда в зависимости от того какими буквами у вас набрано, будет меняться или первая буква, или на второй клик на F3 весь текст. Очень помогает и сберегает нервы.

Word запоминает и хранит в документе последние три места, где вводился или редактировался текст. Чтобы вернуться к одной из этих трёх позиций, нажмите нужное количество раз комбинацию клавиш "Shift"+"F5". При четвёртом нажатии курсор переместится на исходную позицию. Благодаря этому, при открытии уже имеющегося документа для возврата к месту, где работа была прервана, достаточно нажать "Shift"+"F5".

В больших Вордовских документах очень удобно ставить метки на различные места документа, выделяя ключевые слова цветом. Затем, чтобы быстро попасть в нужное место, откройте диалог поиска, нажмите кноку "Больше" для отображения всех функций поиска, и нажав кнопку "Формат" выбирите пункт "Выделение цветом" (в поле "Найти" должно быть пусто).

В Word'e можно перемещаться по предложениям назначив команде SentLeft и SentReght комбинации клавиш (Например, выбираем меню СЕРВИС, НАСТРОЙКА:, КЛАВИАТУРА:, в Категории: выбираем ВСЕ КОМАНДЫ, и в категории КОМАНДЫ находим нужную команду, назначаем клавиши и готово). Также можно и выделять по предложениям назначив командам SentLeftExtend и SentReghtExtend соответствующие комбинации клавиш.

В Word'e можно перемещать строки в тексте. Для этого надо выделить фрагмент текста, затем удерживая клавиши Shift+Alt перемещать его с помощью клавиш управления курсором "Стрелка вверх" и "Стрелка вниз". Переносить можно только строки целиком. А если удерживая эти клавиши нажимать "Стрелка вправо" или "Стрелка влево", можно менять стиль заголовка выделенного фрагмента.

Как ввести полужирный или наклонный текст в MS Word, не пользуясь мышью?
1. Поставить на всех вкладках автоформата (в Word 2000: Сервис|Автозамена) поставить галочки Заменять *полужирный* и _наклонный_.
2а. Если Вы хотите ввести полужирный текст, то его надо заключить в звездочки (*).
2б. Если Вы хотите ввести наклонный текст, то его надо заключить в символы подчеркивания (_).

Иногда Вам может попасть текст в MS Word который либо очень неумело набирали, либо коряво конвертировали из "Plain Text". В таком тексте в конце каждой строки стоит знак конца абзаца, а выравнивание сделано набором бесконечного числа пробелов. Такой текст форматировать очень сложно, при изменении размера бумаги, шрифта или отступов текст расползается в разные стороны и выглядит очень неаккуратно. Простые манипуляции в 5 минут приведут Ваш текст в гораздо более удобный для восприятия.
1. Выбираем "Replace" (Ctrl-H). В "Find What" ставим два пробела, в "Replace With" ставим 1 пробел, нажимаем "Replace All". Повторяем "Replace All" до тех пор, пока есть что-то что заменять. Все, от лишних пробелов мы избавились.
2. Теперь с абзацами. Выбираем "Replace" (Ctrl-H). В "Find What" ставим "^p^t" - т.е. поиск конца параграфа + табуляция, заменяем на "^l^t" - т.е. на переход на другую строку + табуляция - это будут наши начала абзацев.
3. Избавляемся от всех концов абзацев заменяя все "^p" на один пробел.
4. Формируем абзацы - заменяем все "^l" на "^p".
Все, теперь текст гораздо более близок к формату MS Word и над ним можно выполнять стандартные команды форматирования.

Если вы набираете текст и используете несколько шрифтов, им можно назначить комбинации клавиш в меню СЕРВИС, НАСТРОЙКА:, КЛАВИАТУРА:, в Категории: выбираем ШРИФТЫ, находим шрифт, назначаем клавиши.

Если вам нужно добавить сноску в документ, поместите курсор там, где вы хотите ее добавить и выберите Вставка -> Ссылка -> Сноска. В диалоговом окне Сноски в группе "Положение" выберите переключатель "сноски:" и нажмите кнопку Вставить. Напечатайте свою сноску в текстовой области, которая появится внизу страницы.

Если вам нужно, чтобы Word-2000 напечатал книжку на листах формата А4 с двух сторон по две страницы формата А5 на каждой стороне листа, то выберите: Файл -> Параметры страницы -> Зеркальные поля -> ОК ; Файл -> Печать -> (Масштаб)_число страниц на листе -> 2 страницы: (Страницы)_номера -> 16,1,2,15,14,3,4,13,12,5,6,11,10,7,8,9 - для 1 блока по 16 стр. 32,17,18,31,30,19,20,29,28,31,22,27,26,23,24,25 - для 2 блока по 16 стр. и т.д.
Вся книжка будет состоять из блоков по 16 страниц, напечатанных на 4 листах А4 с двух сторон. Листы перегибаются пополам и вкладываются друг в друга по номерам страниц.
Последний блок в книжке может быть укороченным и состоять из 3, 2 или 1 листа, поэтому и номера страниц для него нужно пересчитать отдельно.
Такую книжку удобно переплести как настоящую из типографии. Более подробно об этом можно прочитать в интересной и обстоятельной статье по адресу: http://klirik.narod.ru/izdat/articles/sp.htm

Чтобы комфортнее работать в Word'e при наборе большого текста перейдите к просмотру документа Меню ВИД, ОБЫЧНЫЙ (Ctrl+Alt+N), а для просмотра документа постранично Меню ВИД, РАЗМЕТКА СТРАНИЦЫ (Ctrl+Alt+P).

Вставка образца текста в документ Word

Источник: http://support.microsoft.com/kb/212251/ru

Word дает возможность быстро вставлять образец текста в документ. Для этого напечатайте в документе, в том месте, где вы хотите, чтобы появился текст, =rand() и нажмите клавишу ВВОД.

Появится текст примерно следующего содержания:

Съешь еще этих мягких французских булок, да выпей чаю. Съешь еще этих мягких французских булок, да выпей чаю. Съешь еще этих мягких французских булок, да выпей чаю. Съешь еще этих мягких французских булок, да выпей чаю. Съешь еще этих мягких французских булок, да выпей чаю.¶

Съешь еще этих мягких французских булок, да выпей чаю. Съешь еще этих мягких французских булок, да выпей чаю. Съешь еще этих мягких французских булок, да выпей чаю. Съешь еще этих мягких французских булок, да выпей чаю. Съешь еще этих мягких французских булок, да выпей чаю.¶
...

Данная функция включена по умолчанию. Чтобы ее отключить, следует отключить параметр Заменять при вводе. Для включения или отключения данного параметра выберите в меню Сервис пункт Параметры автозамены, перейдите на вкладку Автозамена и установите или снимите флажок Заменять при вводе.

По умолчанию образец текста содержит три абзаца, в каждом из которых пять предложений. Количество абзацев и предложений можно установить вручную, для чего необходимо указать в скобках соотвествующие числа.

Функция =rand() имеет следующий синтаксис:

=rand(а,п)
где а – количество абзацев, а п– количество предложений в каждом абзаце.

Примеры

=rand(1) – вставка одного абзаца из пяти предложений

=rand(1,1) – вставка одного абзаца из одного предложения.

=rand(1,2) – вставка одного абзаца из двух предложений

=rand(2) – вставка двух абзацев из пяти предложений

=rand(2,1) – вставка двух абзацев из одного предложения

=rand(10) – вставка 10 абзацев из пяти предложений

Примечание. Если пропустить второе число, по умолчанию в абзаце будет пять предложений. Наибольшее число, которое можно ставить в скобках, равно 200 (в зависимости от указанного количества абзацев и предложений это число может быть меньшим).


Оформление текста

Сноски

Сноски являются необходимым атрибутом больших документов различных типов. В Word есть возможность автоматического создания сносок. В этом случае программа автоматически размещает сноску внизу страницы, выбирает для нее подходящий размер шрифта и сохраняет нумерацию, если в документе впоследствии происходят какие нибудь изменения. Сноска состоит из двух частей: текста и ссылки в виде числа возле соответствующего слова документа. В зависимости от того, где помещается текст, сноски могут быть двух типов:

  • обычные — текст помещается на той же странице, что и ссылка
  • концевые — текст расположен в конце документа, главы и т. д.

Создание сноски

Для создания сноски сделайте следующее

  1. Поместите курсор в то место документа, куда следует установить ссылку.
  2. Выполните команду Вставка Ссылка Сноска.
  3. В диалоговом окне Сноска выберите тип сносок в документе:
    4. сноски — их текст может располагаться: • на нижнем поле страницы (параметр Внизу страницы); • в основном тексте ниже последней строки той страницы, на которой расположена ссылка (параметр Внизу текста); концевые сноски — текст таких сносок может располагаться: • в конце документа; • в конце раздела.
  4. Выберите способ нумерации сносок в области Формат. Обычно это арабские цифры, но вы можете задать любые другие символы.
  5. Установите символ, с которого нужно начинать нумерацию, в поле Начать с.
  6. После окончания настройки сносок нажмите кнопку Вставить.
  7. Введите текст сноски. Помните, что если текст обычной сноски будет слишком велик, Word перенесет его на следующую страницу.

Редактирование текста сноски

Если вы работаете в режиме Разметка страницы, текст сноски будет отображаться внизу страницы. Вы сможете отредактировать его в любое время как обычный текст.

Если же вы находитесь в режиме Обычный, текст сноски будет отображаться в области сносок и исчезнет, как только вы закончите редактирование и нажмете кнопку Закрыть в верхней части области. Просмотреть текст можно, подведя курсор к значку ссылки (текст отобразится в виде экранной подсказки). Вы сможете форматировать и исправлять текст сноски как обычный текст. Чтобы сделать это в режиме Обычный, дважды щелкните на значке ссылки — откроется область сносок. Вы также можете перейти в режим Разметка страницы для редактирования текста сноски.

Значок ссылки можно перемещать по тексту как любой символ или выделенный фрагмент текста. Вместе с ним будет перемещаться и текст сноски. Чтобы удалить сноску, нужно выделить значок ссылки и нажать кнопку Delete.

Колонтитулы

Колонтитулы представляют собой текст или графические изображения (иногда и то и другое), которые печатаются в верхней и нижней частях каждой страницы. При этом такой текст может быть одинаковым для группы страниц. Колонтитулы бывают верхние и нижние. Их можно использовать для нумерации страниц, названия организации, текущей даты т. д. Кроме того, в Word имеются элементы автотекста, специально предназначенные для колонтитулов. Эти элементы оформления позволяют быстрее ориентироваться в документе.

Создание колонтитулов

Чтобы создать колонтитулы, выполните команду Вид - Коллонитулы. При этом произойдет автоматический переход в режим Разметка страницы, если вы находились в другом режиме. Также будут созданы верхний и нижний колонтитулы. Курсор при этом переместится в верхний. Одновременно с этим появится панель инструментов Коллонтитулы. Она может существенно облегчить работу, так как на нее вынесены основные функции, которые могут вам понадобиться при работе с колонтитулами.

Ввод, редактирование и оформление текста колонтитула выполняется так же, как и при вводе текста в документ. Для выхода из режима работы с колонтитулами закройте панель инструментов Коллонтитулы при помощи соответствующей кнопки. Если позже колонтитулы нужно будет отредактировать, дважды щелкните левой кнопкой мыши в области колонтитулов, и панель появится снова. Чтобы удалить колонтитул, удалите весь текст, который в нем расположен. При этом лучше включить отображение непечатаемых символов при помощи кнопки Непечатаемые знаки на панели инструментов Стандартная, так как если в области колонтитула остались пробелы или метки конца абзаца, он удален не будет.

При использовании колонтитулов для нумерации страниц обратите внимание на то, что если документ будет переплетен, колонтитулы четных и нечетных страниц должны отличаться. Колонтитулы четных страниц обычно выравниваются по левому краю, нечетных — по правому. Чтобы создать разные колонтитулы для четных и нечетных страниц, сделайте следующее.

  1. Выполните команду Файл Параметры страницы.
  2. Перейдите на вкладку Источник бумаги.
  3. В области Различать колонтитулы установите флажок четных и нечетных страниц.

Работа в режимах Схема документа и Структура

Когда вы работаете с большим документом, вам наверняка часто приходится перемещаться из его одной части в другую. Одно из самых лучших решений проблемы навигации в большом документе — режим Схема документа. Перейти в него можно одним из следующих способов: при помощи кнопки Схема документа на панели инструментов Стандартная (рис. 7.9); выполнив команду Вид Схема документа (рис. 7.10).

Режим Схема документа дает возможность увидеть расположение заголовков в документе. Щелкните на нужном заголовке —и вы сразу переместитесь в соответствующее место документа.Для корректной работы режима Схема документа нужно, чтобы перед этим документ был правильно размечен при помощи стилей. Очень часто, работая с большими документами, пользователи делают не структурное форматирование (то есть с помощью стилей), а визуальное (например, заголовки набирают более крупным размером шрифта и делают его подчеркнутым). Если текст структурирован подобным образом, режим Схема документа вам вряд ли покажется удобным, поэтому лучше пользуйтесь стилями. Вы можете определить их самостоятельно или же воспользоваться заготовками Word, которые можно выбрать в раскрывающемся списке Стиль на панели инструментов Форматирование или области задач Стили и форматирование.

Например, если в тексте есть разделы, подразделы и т. д., то можно выстроить структуру следующим образом:
 стиль Обычный — основной текст;
 стиль Заголовок 1 — названия разделов;
 стиль Заголовок 2 — названия подразделов;
 стиль Заголовок 3 — названия выделенных небольших участков текста;
 стиль Сноска — текст сносок;
 стиль Рисунок — текст подписей под иллюстрациями и т. д.

Режим Структура очень похож на режим Схема документа. Однако если предназна чение режима Схема документа состоит в том, чтобы упростить пользователю пере мещение по тексту, то в режиме Структура можно не только быстро просматривать документ, но и изменять его структуру. В режиме Структура можно перемещать заго ловки совместно с основным текстом и подзаголовками, которые относятся к это му заголовку. Работа в этом режиме также предусматривает грамотное структурирование текста с использованием стилей.

Для перехода в режим Структура нужно воспользоваться одним из способов:  выполнить команду Вид - Структура;  щелкнуть на кнопке в левом нижнем углу окна документа (рис. 7.12). При переходе в режим Структура появится панель инструментов с одноименным названием (рис. 7.13). С ее помощью можно быстро работать с текстом. Используя эту панель, документ можно свернуть или развернуть до определенного уровня, выбрав нужный уровень из списка Показать уровни (рис. 7.14). Если выбрать пункт Показать все уровни, то отобразится весь документ, включая не только подзаголовки, но и основной текст.

Кнопки с изображением стрелок служат для изменения уровня заголовка. Для проведения этой операции необходимо предварительно выделить заголовок и относящийся к нему текст. При нажатии кнопок Повысить уровень и Понизить уровень изменится уровень всех подзаголовков. Кнопка Понизить до обычного текста предназначена для начала ввода основного текста, а также для понижения уровня заголовка до простого текста. Кнопка Повысить уровень до Заголовка 1 поможет быстро изменить заголовок текста на самый высокий. Обратите внимание, что если воспользоваться кнопками Повысить уровень, Понизить уровень, Понизить до обычного текста и Повысить уровень до Заголовка 1, когда требуемый заголовок не выделен (а на нем просто установлен курсор), структура документа нарушится, поскольку будет изменен уровень только этого заголовка.

Предметный указатель

В предметном указателе собираются отдельные слова и фразы, которые являются ключевыми и могут заинтересовать того, кто будет использовать документ. Обычно также указываются номера страниц, где упоминаются эти термины. Word автоматически упорядочивает указатель по алфавиту и к тому же сохраняет правильную нумерацию страниц при редактировании текста. Для создания указателя не потребуется много времени. Если вспоминать о нем не тогда, когда работа уже завершена, а уделить ему внимание во время набора текста, вам это не доставит неудобств. Процесс создания указателя состоит из двух этапов: сначала нужно отметить слова, которые будут использованы в указателе, а затем создать сам указатель.

Включение терминов в указатель

Чтобы при создании документа включить слово или фразу в предметный указатель, выполните следующие действия. 1. Выделите нужный участок текста. 2. Воспользуйтесь сочетанием клавиш Alt+Shift+X. После выделенного текста появит ся поле предметного указателя и будут выведены непечатаемые символы {}. 3. Откроется диалоговое окно Определени элемента указателя (рис. 7.16). Выделенная вами фраза появится в поле основной области Элемента указателя. При необходимости фразу можно отредактировать. Диалоговое окно Определение элемента указателя позволяет сделать следующее.  Создать многоуровневый указатель. Для этого введите фразу, которая должна быть помещена на второй уровень, в поле дополнительный области Элемент указателя.  Задать номер страницы, на которой встречается термин, помещенный в указатель. Для этого установите переключатель Параметры в положение текущая страница.  Дать ссылку на другую фразу или термин. Для этого установите переключатель Параметры в положение перекрестная ссылка и наберите соответствующий текст после слова См. После того как ввод термина будет завершен, нажмите кнопку Пометить. Если вместо этого выбрать кнопку Пометить все, после термина будут указаны номера всех страниц, где он встречается.

Создание указателя

Когда набор текста будет завершен и фразы, которые должны присутствовать в указателе, будут в него внесены, можно переходить к созданию указателя. Для этого сделайте следующее. 1. Установите курсор в то место текста, куда должен быть вставлен указатель. 2. Выполните команду Вставка Ссылка Оглавление и указатели (рис. 7.17). 3. Перейдите на вкладку Указатель (рис. 7.18). 4. Из списка Форматы выберите один из предлагаемых форматов указателей. 5. Чтобы дополнительные элементы располагались под основными, установите переключатель Тип в положение С отступом. Если переключатель установлен в положение Без отступа, дополнительные элементы будут располагаться на од ной строке с основными. 6. Нажмите кнопку ОК, чтобы подтвердить создание указателя. Он появится в документе (рис. 7.19)

Если после создания указателя текст придется редактировать снова, не забудьте обновить указатель, чтобы восстановить нумерацию страниц. Для этого выполни те следующее. 1. Поместите курсор в поле указателя. 2. Нажмите клавишу F9.

Удаление элемента из указателя

Для удаления элемента из указателя нужно удалить весь текст, помещенный в фигурные скобки. Чтобы текст указателя был виден, нужно включить режим отображения непечатаемых символов при помощи кнопки Непечатаемые знаки на панели инструментов Стандартная.

ВНИМАНИЕ Если просто удалить слово из указателя, при обновлении указателя оно снова появится.

Создание автореферата

Word может выполнять даже такие сложные задачи, как анализ текста и создание его краткого содержания — автореферата. Это можно сделать при помощи команды Авторефераты из меню Сервис. В диалоговом окне Автореферат (рис. 7.21) вы можете указать тип автореферата и место, куда программа его поместит. Есть следующие варианты:  будут выделены ключевые моменты документа;  в начало документа;  в новый документ;  вместо оригинала. Также в окне Автореферат можно определить объем реферата (количество предложений или же процентное соотношение реферата и оригинала). Предложения с наибольшим количеством слов, которые чаще всего встречаются в тексте, ложатся в основу реферата. Ключевые слова и предложения автоматически заносятся в свойства документа (поля Ключевые слова и Заметки соответственно). Просмотреть их можно в диало говом окне Свойства. Для его вызова сделайте следующее. 1. Выполните команду Файл Свойства. 2. Перейдите на вкладку Документ. Создание оглавления Автоматическое создание оглавления часто используется при работе с большими документами. Если вы написали книгу или завершили создание рабочего или учеб ного проекта, то перед распечаткой окончательного варианта документа желатель но создать оглавление. Оглавление поможет читателю сориентироваться в вашей работе, выделить для себя главное и сосредоточиться на изучении наиболее инте ресных для него моментов. Оглавление может помочь и при навигации в электрон ном документе. Если вы поместите оглавление в начало документа, с него можно будет начать просмотр. Создание оглавления займет совсем немного времени, если, конечно, документ оформлен соответствующим образом. Если при создании документа вы не поле нились его структурировать должным образом, Word составит оглавление за счи танные секунды, и при этом оно будет построено правильно. Сборка оглавления происходит в несколько этапов. 1. Word находит заголовки с заданными стилями. 2. Заголовки сортируются по уровням. 3. Каждый заголовок снабжается соответствующим номером страницы. Перечень заголовков и соответствующих им страниц вставляется автоматически. Вам только нужно будет набрать слово Оглавление. Для создания оглавления сделайте следующее. 1. Установите курсор в место, где будет располагаться оглавление. 2. Выполните команду Вставка Ссылка Оглавление и указатели. 3. Перейдите на вкладку Оглавление (рис. 7.22). 4. Выберите стиль оглавления в списке Форматы. 5. Установите флажок Показать номера страниц для показа номеров страниц каждого элемента списка. 6. Установите флажок Номера страниц по правому полю для выравнивания номеров страниц по правому полю. 7. Выберите тип линий (точечные или пунктирные), которые будут вставлены между элементами оглавления и номерами страниц (рис. 7.23). Это можно сделать только при установленном флажке Номера страниц по правому полю. 8. Задайте количество уровней оглавления в поле Уровни. Количество уровней не должно быть больше количества стилей заголовков. 9. Нажмите кнопку ОК, чтобы подтвердить создание оглавления. Оно будет вставлено в документ (рис. 7.24). Если после создания оглавления в документ вносились правки, поместите курсор в поле оглавления и нажмите клавишу F9 для его обновления.


Word: Выделение текста

Выделение текста

Стандартные способы выделения текста
Для того, чтобы выделить предложение, нужно кликнуть на любом его слове при нажатой клавише CTRL. Если требуется выделить слово, на нем достаточно два раза щелкнуть мышью. Если щелкнуть три раза, выделится текущий абзац.

Способы выделения текста, используя отступ документа
Клик левой клавишей мышки на левом отступе документа:

  1. Одинарный - выделить строку
  2. Двойной - выделить абзац
  3. Тройной - выделить весь текст.
  4. Одинарный при нажатом Ctrl - выделить весь текст. Последнюю операцию можно проделать также с помощью клавиш CTRL+A.

Если нажать ALT и начать выделение мышкой, то будет выделяться прямоугольный фрагмент текста

Чтобы выделить весь абзац, нужно поставить курсор в начало или конец абзаца и нажать Ctrl+Shift+стрелка вверх (если курсор стоит в конце абзаца), Ctrl+Shift+стрелка вниз (если курсор стоит в начале абзаца).

Проблемой многих является выделение большого участка, ведь при достижении указателем нижнего края окна документ начинает прокручиваться быстро, и остановить его в нужном месте очень непросто. Поэтому для выделения больших участков текста используйте клавишу Shift. Если она нажата, вы легко сможете выделить любой участок.

Многократное выделение.
Как быть, если тот текст, в котором надо провести замену, разбросан по всему документу? Тут бы подошло многократное выделение. В WordXP такая возможность есть - достаточно при выделении нового фрагмента удерживать клавишу Ctrl, и имеющееся выделение сброшено не будет

Копирование фрагментов без буфера обмена

Копировать и перемещать участки текста можно не только с помощью буфера обмена. В рамках небольшого участка документа эти операции можно выполнять мышкой. Для перемещения выделите нужный участок и наведите на него курсор. Нажмите кнопку мыши и, не отпуская ее, потяните курсор на то место, куда необходимо вставить текст. Когда вы отпустите кнопку мыши, текст будет перемещен. Чтобы при помощи мышки скопировать текст, необходимо выполнять те же действия при нажатой кнопке CTRL. При этом возле курсора появится значок +.

Другой способ. Выделите нужный фрагмент. Далее нажмите и удерживайте клавиши Shift и Ctrl, установите курсор в нужном месте и нажмите правой кнопкой мыши. В результате выделенный ранее текст появится в этом месте, минуя буфер обмена.


WORD: Горячие клавиши

Горячие клавиши и комбинации клавиш

Чтобы выделить в Word'е вертикальный блок текста, надо предварительно нажать комбинацию клавиш "Ctrl"+"Shift"+"F8". Кроме того, выделить вертикальный блок можно с помощью мышки, удерживая клавишу "Alt".

В Word работая в режиме кириллицы, иногда нужны знаки которые доступны лишь в режиме латиницы напр. @, $, & чтобы не переключать режимы достаточно нажать клавишу Alt + Ctrl + нужную (или Shft+Alt+Ctrl+нужная).

Горячие клавиши

  • Полужирный текст - нажимаем Ctrl+B (или в русскоязычном режиме - Ctrl+И). Выключается аналогично.
  • Курсивный текст - Ctrl+I или Сtrl+Y (в русском - Ctrl+Ш или Ctrl+Н).
  • Подчёркнутый текст - Ctrl+U (в русском - Ctrl+Г)
  • Текст с двойным подчёркиванием - Ctrl+Shift+D (Ctrl+Shift+в)
  • Текст, набранный капителями (уменьшенными заглавными буквами) - Ctrl+Shift+K (Ctrl+Shift+Л) (для изменения данных атрибутов у целого слова, его вовсе не обязательно выделять целиком. Достаточно лишь, чтобы курсор находился внутри слова).
  • Выравнивание абзацев: влево - Ctrl+q (Ctrl+й);
  • вправо - Ctrl+r (Ctrl+к);
  • по центру - Ctrl+e (Ctrl+у)
  • по формату - Ctrl+j (Ctrl+о)
  • маркированный список - Ctrl+Shift+L (Ctrl+Shift+д)
  • Сдвиг абзаца вправо Ctrl+M (Ctrl+ь)
  • Увеличение отступа слева (кроме первой строки) - Ctrl+T (Ctrl+е)
  • Печать документа (в Word и почти во всех других программах) - Ctrl+P (ctrl+З).

Несколько полезных замечаний для тех, кто печатает вслепую и ненавидит использовать мышь:
Изменить шрифт в тексте - нажимаем Ctrl+Shift+F (Ctrl+Shift+А), при этом активизируется окно смены шрифта в панели форматирования. Печатаем название нужного шрифта в этой панели (обычно достаточно нескольких первых символов - далее Windows достраивает имя автоматичеки) и нажимаем "Ввод".
Изменить стиль шрифта или абзаца - аналогично, нажимаем Ctrl+Shift+S (Ctrl+Shift+Ы), и вводим имя шрифта, например, "Заголовок 1". После нажатия "Ввод", к абзацу применяется введённый стиль, а если стиля не существует, то он создаётся на основании форматирования абзаца, где стоит курсор.
Ввод концевой сноски. Можно, конечно, для этого лезть в меню, но это опять подразумевает использование мыши! Гораздо проще нажать Ctrl+Alt+F (Ctrl+Alt+А), и в указанном месте текста сразу появится сноска, а курсор переместится к низу страницы, где вы сможете ввести её описание.

Очень легко удалить неиспользуемые кнопки с панели, просто вытащив их с панели мышкой при нажатом Alt, точно так же при нажатом Alt можно поменять расположение кнопок не залезая в окна опций и настроек (с нажатым Alt+Ctrl - можно сделать копию кнопки). Такими же манипуляциями можно кнопки поместить в меню и разделы меню в toolbar с кнопками.

Иногда возникает проблема и нужно изменить регистр букв, для этого становимся на слове в котором нужно изменить регистр (или выделяем несколько слов) и нажимаем Shift+F3 несколько раз, в зависимости как вы хотите: Все Буквы Большие В Начале Слов, ПРОПИСНЫЕ или строчные.


PowerPoint: Общие советы

Печать в черно-белом виде

Если попробовать распечатать красочную презентацию на чёрно-белом лазерном принтере, то можете получить некрасивый результат. Лучше, когда выводите на печать (через меню Файл - печать), то увидите, что в этом окне есть возможность выбрать печать черно-белую или в оттенках серого (предпочтильнее).


Книги

Word 2003/2007. Народные советы

В книге собраны советы, подсказки и секреты работы с текстовым редактором Microsoft Word 2003/2007, позволяющие существенно повысить эффективность и качество работы с текстом. Все примеры проверены автором лично и представлены в виде подробных пошаговых инструкций так, чтобы разобраться и применить их на практике смог любой пользователь.

Приобрести книгу


Полезные ссылки

Word Expert

Сайт Word Expert - профессиональная работа с текстом содержит большое количество макросов, статей и другой полезной информации.

Планета Excel

Полезный ресурс Планета Excel содержит множество советов, приемов, трюков для MS Excel. Имеется форум, на котором можно обсудить свою проблему.


Outlook: Общие советы

Microsoft Outlook является мощным коммуникационным приложением, помогающим более эффективно распоряжаться информацией, а также предоставляющим возможность быстро публиковать данные и работать совместно с коллегами.

Outlook предоставляет все средства, нужные для эффективной работы с электронной почтой и управления электронными сообщениями. Используя Outlook, можно:

  • отсылать и получать электронные сообщения
  • прилагать файлы к вашим сообщениям
  • создавать адресную книгу и управлять ей
  • упорядочивать и архивировать сообщения
  • персонализировать ваши сообщения

Outlook также можно использовать для отправки мгновенных сообщений.

В области уведомлений не выводится значок конверта при появлении новых писем

Если у вас Microsoft Outlook 2010 не показывает значок конверта при появлении новых писем, вы можете восстановить нужную настройку.

Откройте Outlook 2010 и в меню File выберите команду Options. Далее выберите раздел Mail в левой части навигационной панели. В секции Message arrival поставьте флажок Show an envelope icon in the taskbar.

В случае если интегрированный в Outlook 2007 агрегатор RSS-лент не используется, то следует отключить его и освободить программу от выполнения ненужной работы. Откройте окно параметров приложения и на вкладке "Дополнительно" щёлкните по одноимённой кнопке. Появится окошко с дополнительными настройками программы, в котором нужно снять галочку с пункта "Синхронизировать RSS-каналы с общим списком каналов".

Проверенный способ ускорения работы программы - отключите ненужные надстройки. В Outlook 2007 модуль управления списком установленных расширений представлен в центре управления безопасностью.

Добавление комментариев к сообщениям в OUTLOOK

Вы можете изменить тему полученного и открытого сообщения, чтобы добавить свой собственный текст, чтобы облегчить себе последующий поиск этого сообщения.

Разгребаем почту

Если после отпуска вам приходится разгребать очень много почты, то попробуйте использовать подсветку писем в зависимости от условий.

Возможно, в первую очередь стоит прочитать письма, в которых вы среди получателей (to), а затем уже те, в которых в в копии (cc). Также полезно уделить больше времени письмам начальника. Вот именно эти задачи можно упростить, добавив немного цвета к письмам. Для этого идем в меню Tools | Organize, затем на вкладке Colors задаем условия.

Щелкнув по кнопке Automatic Formatting окна Ways to Organize Inbox можно управлять набором правил, задавать более сложное форматирование и значительно более сложные условия.

Сохранение почтовой базы

Для сохранения почтовой базы рекомендуется использовать МАСТЕР ИМПОРТА И ЭКСПОРТА (ФАЙЛ/ИМПОРТ И ЭКСПОРТ). Достаточно выбрать из списка действий данного мастера элемент ЭКСПОРТ В ФАЙЛ, после чего выбрать тип создаваемого файла, путь к нему, а также папку, сообщения из которой будут помещены в файл.

Для помещения сообщений из файла обратно в Outlook достаточно воспользоваться элементом ИМПОРТ ИЗ ДРУГОЙ ПРОГРАММЫ ИЛИ ФАЙЛА мастера МАСТЕР ИМПОРТА И ЭКСПОРТА.

Сохранение адресной книги

Для сохранения адресной книги выберите Файл | Экспорт | Адресная книга. Можно также вручную сохранить файл *.wab, который находится в папке C:\Documents and Settings\UserName\Local Settings\Application Data\Microsoft\Address Book.

Перенос учетных записей

Чтобы перенести учетные записи электронной почты на другой компьютер, необходимо на вашем текущем компьютере скопировать данные из реестра (смотри Справочник по реестру Windows)

Календарь

Для вывода номеров недели в календаре Outlook: Сервис | Параметры | Настройки | Параметры Календаря | Показывать номера недель.

Запрет на загрузку слишком больших писем

Если у вас дорогой Интернет, то вы можете запретить почтовому клиенту загружать сообщения, размер которых больше указанного. Для этого достаточно воспользоваться диалогом НАСТРОЙКИ ОТПРАВКИ И ПОЛУЧЕНИЯ - ВСЕ УЧЕТНЫЕ ЗАПИСИ. В этом диалоге нужно выделить вашу учетную запись, после чего установить переключатель области ПАРАМЕТРЫ ПАПКИ в положение ЗАГРУЖАТЬ ТОЛЬКО ЗАГОЛОВКИ СООБЩЕНИЙ С РАЗМЕРОМ БОЛЬШЕ, после чего в поле ниже указать максимальный размер сообщений в Кбайт. Если сообщение будет меньше указанного вами размера, тогда клиент загрузит его полностью. В противном случае клиент загрузит лишь заголовок сообщений. В дальнейшем вы вручную сможете полностью загрузить сообщение, если оно вам необходимо.

Чтобы отобразить диалог НАСТРОЙКИ ОТПРАВКИ И ПОЛУЧЕНИЯ - ВСЕ УЧЕТНЫЕ ЗАПИСИ, необходимо нажать на кнопку ОТПРАВИТЬ И ПОЛУЧИТЬ на вкладке НАСТРОЙКА ПОЧТЫ диалога ПАРАМЕТРЫ. После этого перед вами отобразится диалог ГРУППЫ ОТПРАВКИ И ПОЛУЧЕНИЯ, в котором нужно выделить группу ВСЕ УЧЕТНЫЕ ЗАПИСИ и нажать на кнопку ИЗМЕНИТЬ.

Ответ на другой адрес

Существует возможность создания письма, ответ на которое будет отправляться не на адрес отправителя, а на другой адрес, например, на адрес секретарши, а не директора, отправившего письмо.

Для ее использования достаточно во время создания нового письма воспользоваться флажком и полем ОТПРАВЛЯТЬ ОТВЕТЫ диалога ПАРАМЕТРЫ СООБЩЕНИЯ (или кнопкой ВЫБОР ИМЕН этого же диалога). Данный диалог можно отобразить с помощью кнопки справа от раздела ПАРАМЕТРЫ ленты СООБЩЕНИЕ. Кроме того, данный диалог можно отобразить с помощью кнопки НАПРАВЛЯТЬ ОТВЕТЫ В раздела ДОПОЛНИТЕЛЬНЫЕ ПАРАМЕТРЫ ленты ПАРАМЕТРЫ.